LAUNCHED: Hold Ctrl to temporarily disable all snapping

When fine tunning design, it’s important to do it without snapping.

But Figma’s snapping system is also great.

I think it would be great to have a quick way to instantly disable snapping without having to go to “preferences”.

It could be by just pressing CTRL key** (or other - maybe “S”) after start dragging the element to not conflict with other actions - if this is he case**.

** To be honest, I don’t really know what does the actual pressing of CTRL key. It shows a down arrow but I’m yet to discover what it does.


Yes please provide a way to quickly turn off all Snap To options! It’s a pain to click the drop-down and individually uncheck all three off and back on again! I feel like this should have more votes…


+1 so annoying


Upvoted! There should be a single key modifier you can use while dragging to temporarily disable all snapping. MS Office / PowerPoint uses Alt for this (on PC). Possibly assign to Ctrl or even something like Space? Should be active only while dragging, and only while modifier key is held down.

No matter how smart a snapping algorithm is, there will be times when it gets it wrong and snaps to the wrong thing, especially in a complex layout. A quick way to bypass this would decrease the annoyance factor by quite a bit.


Upvoted as well and I echo Jim_Doria. There should be a special key I hold down while dragging an element to signify that snapping should be ignored.


Couldn’t agree more. Photoshop has had this ability for (checks watch) 15 years? I’ve been clamoring for it in Illustrator for about the same length of time, apparently into the void. Don’t be a void, Figma, this feature is a no-brainer!


Can’t believe there’s no key to hold to disable snapping given all the other amazing shortcuts!


It will be useful! Please!

yes, please and thank you

It would be nice to have a checkbox (and shortcut) in each element of the tree to ignore it from snapping.
Sometimes it’s not possible to align something because of so much objects around.
I tried locking them but it’s not possible (of course, because most of the time it’s useful to align to locked objects :slight_smile:

Hey All,

With the launch of today’s Little Big Updates, you can now hold ctrl to temporarily disable all snapping! :tada:

1 Like

Hey @dvaliao
This is so great!
I’ve tried it and I was actually going to ask you if this would be in next Figma launch because it wasn’t working.
But then I tried the “S” key and it worked!
Feels so good. Thank you all!
(CTRL isn’t working though : )

1 Like

Thanks for the feedback, @Ricardo_Desirat!

The keyboard shortcut may differ, depending on your keyboard. Happy to hear that the “S” key is working!