How To Show Tabs in Full Screen

This new “feature” is killing easily swapping between tabs. I HATE IT. How do I turn this OFF?


Hi @Jamison_Mergens,

Sorry for the frustration. In full screen mode, when hovering towards the top of your screen, select View > Show Tabs in Full Screen


You saved my life. My .02, make these sort of “features” opt-in in the future :slight_smile:


Ahh, I am so glad to spot this thread. I updated my figma and so annoyed at not able to switch my files, besides its not at all intuitive.
I am mostly working on 4-6 projects. I liked them sticky before.


Hiding the tabs in full screen is very frustrating. especially when you working simultaneity on more than one screen + the keyboard shortcut is impossible on a laptop (Mackbook pro in my case)!

why not showing them when the cursor hovers over the top of the screen where they used to be?


Hey @Nitzan_Ron,

You can still see tabs in full screen. In full screen mode, when hovering towards the top of your screen, select View > Show Tabs in Full Screen.


I’m sooo happy I found this thread. I was getting really frustrated a few days. :sweat_smile: I was jumping in and out of full screen to not have to go back to recents all the time. Glad I could opt-out, frustrating that I had to.


Hey guys!! This new thing from Figma really sucks :smiley: Noone could ever ask for this stupid improvement :(.

Above all that there is no option View > Show Tabs in Full Screen. How come?

1 Like

This feature is really annoying! Why I must seek for global navigation block inside some menu?! Please fix this.

1 Like

This isn’t working for me, I can’t find the option :upside_down_face::sob:

1 Like

Hey @Ondrej_Kulatka,

Please let me know if you’re not using a macOS, but there is an option to Show Tabs in Full Screen as instructed above.


Hey @George_Triadafillou,

What OS are you using? Are you able to provide a screenshot of what you’re seeing?

1 Like

Tabs are not showing anymore in full-screen mode, I have to keep toggling between full-screen mode and normal mode to be able to access my tab menu. It is frustrating!!!

1 Like

View → Show Tabs in Full Screen

For Windows I don’t have fresh screenshots but it should be somewhere under this arrow menu. If you have a fresh screenshot, send it to me please and I’ll attach it.

UPD: there doesn’t seem to be an option for this on Windows. If you know where to find it, send it here. ¯_(ツ)_/¯


I have the same issue

Thank you Gleb

I thought the update broke Figma. extremely annoying :tired_face:

Thanks for the solution.

1 Like

Ahah perfect example of what you never have to do for an update :slight_smile:

1 Like

1. Describe the problem your experiencing and how your idea helps solve this
In the Mac desktop app tabs for opened files (top of the window) get hidden when the window is set to fullscreen

  1. Add as much context as possible (screenshots, Figma files, mockups, etc.)

I’ll be great to have tabs and the home button back (it was working before the last update)

  1. Ask questions to bring the community into the conversation
    (e.g. Does anyone else experience this? Is anyone using a plugin or workaround to help solve this?, etc.