Figma is getting very slow

I have tried on file where lots of pages were there and also where only one or two pages with not more than 5 frames working on. but still, Figma got frozen while zooming in and out and was not able to edit, place, remove elements quickly.

Can anyone facing the same issue and if anyone gets a solution for it do guide me.

Thanks

17 Likes

Hi there. Same issue here. I posted in this thread: Applying text styles is slow - Get Help - Figma Support Forum, maybe you can join :slight_smile: Opened up a support ticket but haven’t heard from Figma yet.

3 Likes

I’m facing the same issue. After update Mac OS to Monterey 12.2, Figma starts to lag as hell in bigger files. Before the update it was working smoothly in the same file but now it’s impossible to work with it. I contacted the Figma support and they respond they are already investigating it so hopefully they will fix it soon. Seems they know about this issue.

6 Likes

:wave: Hello everybody,

Did you try any of the following solutions:

I have tried almost everything and nothing helped. And, as I said, it was working correctly 1 - 2 days ago in the same file and now it is totally broken after Mac OS last update. So, definitely it’s not problem with the memory or some HW acceleration or whatever.

4 Likes

Having the same issue. I’m using two different computers and only my personal is having this slow performance issue; the other one is working smoothly. Both with Mac OS Monterey 12.1.

I tried to reset the computer and making sure the browsers have the right set up, but the only program having this issue is Figma desktop app/browser. I also realized my image styles are not working properly, maybe due to the same issue.

Captura de Pantalla 2022-01-27 a la(s) 9.31.43

1 Like

The same happened on my old MacBook Pro 15" mid-2015, after the update to Monterey.

1 Like

This is the e-mail I got from the Figma support. Seems they know about this bug with lagging. We just need to wait till they fix it but who knows when they will. Till then, Figma is unusable at all for me.

3 Likes

Btw, my friend with Monterey 12.0.1 has no this issue with lagging. So, probably there is some problem with the newer versions of Mac OS updates.

Guys, I solved the issue for me! If you are running any “cleaning”, “optimizing”, “speed-up”, anti-virus or VPN apps on your Mac, it can cause these kinds of problems. I had Clean My Mac X app installed on my Mac and after uninstalling it with all its files (checked also by Find Any File ) Figma started to work without any lag. Try it, maybe it will help you, too!!

2 Likes

Hello,

Andrej I don’t have any apps like that.

Over night my figma files started lagging a lot, I removed a lot of redundant pages, decreased the amount of components with alot and cleared the cache. And then It seemed to be working fine for approxiametly 10 minutes then the lagging returned.

Mac Os Big Sur 11.6
MacBook Pro (13-inch, M1, 2020)

1 Like

I’m having the same issues here. After a few minutes (often already after 30 Seconds) my larger files start lagging. It then gets worse and worse up to the point, that i have to restart Figma since it is no longer usable. The issue appears in the desktop app as well as in chrome (although it takes a little longer to start lagging in chrome). The problem appears on my larger files (around 50-125 mb on export size). Smaller files are still fast.

What i already tried

  • reinstalled figmas desktop app → same problems
  • Cleared chromes browser cache → same problems
  • work on separate pages in my larger files where i only place 1-5 artboards → same problems
  • Cleaning up my files a few weeks ago solved the problem on one of the large files → but the problems are coming back again right now.
  • Exporting and reimporting the large files a few weeks ago solved the problem for a short period of time → but the same problems are reoccurring again at the moment

Would be great if these problems could be fixed :). Cheers, Ferdinand

Specs:
Mac OS 12.1 Monterey
newest version of the figma desktop app 107.1
iMac 2019 with 3,7GHz 6-Core Intel Core i5, 40GB RAM and Radeon Pro 580X 8 GB

UPDATE: I updated to Mac OS 12.2.1 → same problems

4 Likes

Tips from figma support appreciated, but after trying virtually every option proposed or that I can think of, I’ve needed to switch back to Sketch. That’s a nightmare if you’ve worked with FIgma libraries and files for over a year. I’ll keep watch over this but Figma is unusable now - gut tells me it’s tied to the Monterey 12.1 update made but can’t be sure. Ugh.

9 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.