Figma Support Forum

[Figma Beta] Why have tabs been removed when the window is maximized?

Using Figma Beta on macOS. I prefer using Figma maximized. Received an update earlier today. When the application window isn’t maximized, everything is as expected — I have visible access to the hamburger menu, and separate tabs I work with.

After the update, on hitting maximize, the tabs are gone. It’s only the hamburger menu and the tool bar. To switch to another open project or to go to the project browser, I have to restore the window from maximized, make the switch, then maximize again.

Why the change? Is there a shortcut we now need to know to cycle between tabs? Pretty sure a shortcut exists, but haven’t been using it. Between point & click or guessing the position & cycle between tabs, I’ll always choose the former.

If you are proceeding with this release, please consider an application preference to rollback to the previous window layout.

I think this may be a bug, you can report it to Figma support team via the bug report form.

Thanks, Gleb. I’ve raised a ticket.

Well, I’d say the new behaviour could be preferable when viewing a prototype – I know that’s been a wish of mine.

…but agree when designing in full-screen (which I do sometimes, when really wanting to focus) it’d be useful to either return the tabs, or have a way to optionally show them, perhaps via a toggle key? (And/or a preference… but that’s usually the cop out answer, isn’t it?! :slight_smile: )

I recently found out there is a setting for this, try to check the menubar menus for something like Show tab bar or Show toolbar in full screen. I don’t have beta installed so I can’t check.

2 Likes

Ah so there is, it’s “Hide Tabs In Full Screen” in the “View” menu. Looks like that option defaults to “on” in the current beta (96.3)

So, at least on the Mac I can assign a keyboard shortcut via the “Keyboard > Shortcuts” System Preference panel. :+1:

2 Likes