Figma Support Forum

After delay sometimes greyed out.. why?!

While figma is great, intuitive and easy to use in some aspects, sometimes it drives me crazy with the, one would think, most basic functionalities not working under any logical pattern. The biggest issue for me is the “past in place” which simply doesnt work at all, and the next is the “after delay” prototyping mode. sometimes it is just greyed out and you can’t select it and there is no way in hell you can understand why.

can someone explain the weird logic behind it? how to contact the developers to fix it because it cant be anything else but a bug? it is driving me nuts. im wasting so much time in something that it is supposed to be pretty straightforward…

For the “paste in place” issue, when copying and pasting a shape or frame into a new frame, it should retain the same position. You might be experiencing a bug, so if you can, it would really help if you could record this issues, so I can show it to the team and let them know.

In terms of the “after delay” prototyping interaction, it is only enabled when you have a main frame selected rather than a nested object or frame. I’d double check whether the object you’re trying to get the “after delay” interaction to apply to is nested.

i was trying to apply the “after delay” option to animate variants inside a component. i guess it does not work in that case. but i think it would be very useful to have all the elements of an animation wrapped up in such way

You should be able to apply the “after delay” to variants of a component such as this spinner:

I’m not really sure why it’s not showing up as an option for you, but if you’re willing to share your file I can take a look at it to help diagnose the problem.

Hi! thanks for the assistance.
I’m not sure if i can publicly share the document as there might be sensible information… but maybe this screenshot can help. here’s how i got it set up. just a simple loader similar to the one you shared. 4 variants. try to animate these, but “after delay” appears greyed out.

Hmm everything looks fine… I know it’s a little hacky, but you could find a spinner in a Figma community file, copy it to your file, and then adjusting the styling to match. Also feel free to copy the spinner from this file I made.

Thanks Ana!
I tried bringing your file into mine and looks like i have an outdated version, where that specific functionality is not available. the following popup showed when i tried to play the spinner animation.


And indeed the animation did not work. However, figma did not suggested any updates so I’m not sure why i can’t use that feature. I will try to reinstall and see if that helps

Hey @Hernan_A,

This is most likely because you’re not on the interactive components beta yet. You can be added then turn on interactive components for your file. You can sign-up here:
▶ Sign up for the Interactive Components beta →

1 Like

oh, i didn’t know it was a beta feature… i thought i was having a bug. i will sign up then
Thanks for your assistance

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.