Solved - Zoom bug is back. Too large increments on Desktop version, weird ones in Browser version

The zoom bug is back. The desktop version of Figma has huge steps, while the browser version of Figma still has small steps, but these are still weird.

When you hold CTRL and use the mouse wheel, you can zoom in and out of your design. If memory serves me correct, both directions had stops of 10%. So 100%, 110%, 120% etc.

  • On the browser version, these steps are now: 100%, 106%, 112%, 119%, 126%, 133%, 141%, 149%, etc… which are weird steps. But I can live with that.

  • The desktop is worse. These steps are now: 100%, 532%, 2827%, 15029%, 25600%. Negative is totally different, and is now: 100%, 19%, 4%, 2% and stops there.

I use this way of zooming intensely. The product is useless the way zoom now works. So can you please fix this asap?!

Windows 8.1, with…

  • Desktop > Figma Desktop App version 112.2
  • Browser > Firefox version 99.0 (64 bit)

While the system did not provide me with alternate topics that had this same subject, I now found out there are, and they also feature solutions.

I have now enabled the ‘Use alternate zoom handling’ option in the Preferences… but had to find out myself that I had to enable this.


Wouldn’t it be handier… if Figma posted a blogpost or log about what was changed, and how to solve things? We have to find out what options to choose ourselves.

The de/increment is still a weird percentage… but at least better than jumping 500% with one stop.


The solution works perfectly in a design file, but there aren’t such an option in FigJam… Come on Figma please fix this!

Found something: if you hold z you get zoom cursor which you can use to zoom to selected region or have a simple zoom in with a single click. Didn’t find out how to zoom out though. Never used it, so I don’t know if this feature was there before.

Heavy damage to usability anyway. Found some problems with “smart guides” also.

On windows, holding the ALT button will give you the toggle to zoom out.

1 Like

I found the zoom increments to be related to the interface scale, at least on my system.
Having Use alternate zoom handling off and the interface scaled will lead to heavy jumps when zooming.

Same for mac desktop app (m1, Monterey). And we don’t have that “alternate zoom” thing in Prefs.

Found out today that the option that you can enable in the Preferences, is NOT SAVED. Non of the changes are saved in the desktop version. So that’s probably broken now.

Already added another prio topic… so hope they see it :

PRIO: Preferences aren’t saved?! - Previously: The ‘Use alternate zoom handling’ is NOT saved in your Preferences!?

Why has this topic been updated? I didn’t ask the community… but I’m reporting a bug in the system. This is news for programmers, not the other users who can’t change anything anyway. The Figma forum should have a ‘bug’ topic, so we can report bugs.


I think this is solved.

This topic was automatically closed after 30 days. New replies are no longer allowed.