Figma Glitches on Intel UHD 730. WebGL context lost error

Hello Everyone, I am not sure if this is the right place to post the query. But I am facing alot of performance issues while using figma with my new Intel 11th Gen i5 11400 on intel uhd 730. I don’t have a graphic card installed in this pc. I have tried multiple drivers and ports but the problem still remain the same.

The figma screen is lagging like hell as soon as I start panning around and turns to completely grey.

Please help. Attached is the screenshot

1 Like

Restart Figma. Open the design file. Open console. Try to reproduce the gray screen issue. Check the console for errors.

Is there an error “WebGL: CONTEXT_LOST_WEBGL: loseContext: context lost”?

@tank666 here’s the attachment for the error. After this the whole screen got grey as soon as I started panning and zoomed in. And I have to restart the figma and it goes again and again not letting me to work at all. :frowning:

Launching Figma with the --disable-gpu-compositing flag helped me.

Create or edit a Figma shortcut so that the Object field reads: "C:\Users\%USERNAME%\AppData\Local\Figma\Figma.exe" --disable-gpu-compositing.

You can also launch Figma through the command prompt.


@tank666 it Worked :slight_smile: . A little laggy but overall alot better than Basic Adapter Driver experience. Thanks alot man. You saved my life. :slight_smile: :+1:

@tank666 did it disabled the GPU acceleration? And how this issue will be resolved without disabling it? Thanks again

Unfortunately, I have not found another way. You can try changing the parameters in the GPU driver settings. Also contact support, maybe you will be prompted for a different solution.

@tank666 it resolved it to some extent but didn’t fully resolved. The figma get’s stuck completely very often and starts to work again. :frowning: I believe we have to wait for the update from either figma or intel hd driver. Let’s see. Thanks anyway.

Bump. Have the same issue with UHD 750

I have the same problem with Intel UHD 730. --disable-gpu-compositing flag does not solve the problem

Do you have a WebGL: CONTEXT_LOST_WEBGL: loseContext: context lost error in your console?

on a hardware accelerated browser getting this error. Without hardware acceleration, everything is fine (for now).
I just don’t have time to see this error in the application. The application turns into a “gray brick”

getting error when running this way

C:\Users\admin\AppData\Local\Figma\Figma.exe --disable-gpu-compositing

the latest version of drivers from intel is installed ( 14.07.2021)

Save debug info, open that file and find the table under “Graphics” section. Is “disable_software” set for “gpu_compositing”?

i have this

updated the program to the latest version and updated the drivers on the video to the latest, the problem did not go away.

is there any solution?

Figma works fine in FireFox, but in Chrome and in the application the same problem as the author of the post (UHD 750).

1 Like

I’m confirm this problem. I have an I5-11600 (UHD 750) and also have this problem. Figma works well in Firefox, but in all chromium browsers - crashing browser (or the program does not respond)

Did you tried the latest hd driver from intel on the link below. It worked for me last time when I installed. Because after that I moved to external GPU so not sure if it still works. Give it a try.

1 Like