Boolean component property does not hide layer

Hi, I’m using component property and noticed when toggle on/off a boolean, it doesn’t hide that layer in the layer panel. Any ideas? tia

You can see in your screenshot that the boolean property works correctly and hides the icons on the left and right. Maybe you want the button to shrink by the width of the hidden objects?

ah, that’s my mistake. I thought it will completed hide the layer (not shown as turn off layer). Problem solved. Thanks anyway