0px layers now take up 1px space with Auto Layout

Previously, 0px or 0.00001px wide layers did not take up any space inside an Auto layout frame. This made it possible to hide elements for smart animate, or use only X or Y.

This changed with the latest update and all elements are pushed 1px, but the parent frame does not expand to “hug” the new size, resulting in 1px offsets wherever these are used.

21 Likes

Please, fix it. All offsets were changed in my design system…

1 Like

+1 with the exact same problem…

1 Like

The same problem is within our company Design System. I have already issued a question about it to support with no answer yet. I hope for a quick fix.

5 Likes

+1 It is breaking everything

2 Likes

+1, seems like a breaking change

1 Like

+1 We use lots of zero-height frames in our design system

1 Like

+1 we used a lot of them in our design system, it kinda breaks the whole idea now at 1px

1 Like

+1 , having the same issue with our components

1 Like

Yes, something has changed with 0px frames, involving Auto Layout. They are fine until set to “Fill container”, which makes them grow, or add a 0.5px margin/Y-axis offset.

2 Likes

0,0001 is bad practice, draw a line, set stroke width to 0 then make a frame around it and you get a true zero-width/height frame :sunglasses:

+1 should be default 0 if we already set it to 0.0001

There also are issues with these so-called true 0px frames you describe. Namely a 0.5 y-axis offset when setting to “Fill container”:

2 Likes

yeah,it happens

1 Like

Both our web and product design systems are now severely broken. Please, either introduce absolute zero dimensions, or revert back to the relative 0.001px value. This helped exactly no one.

3 Likes

everything is damaged now, REVERT CHANGES ASAP!!!

2 Likes

Same problem!

Same issue here. It’s so annoying. I hope for a fix soon…

Hey All,

Thanks for flagging this! This is a bug. Our team is already proactively working on a solution. We’ll update you as soon as we can.

5 Likes

Glad I found this thread before I spent hours trying to figure out what I was doing wrong.

2 Likes