Figma Support Forum

Pasted instance doesn't keep formatting

  • I have a shared library
  • when copying from main file to another file with the library, some components get a totally new formatting (stroke color, background color, font color etc)
  • not all items have this behavior
  • I believe it’s something related to creating variations of a component based on a master component

Watch it happening here: (can’t attach file) (can’t link to Loom)
www - dot - Loom - dot - com - /share/9d471adb93b04ffc83bae652d57edc03

Video 2 - another case if the same issue /share/c396e5cb135c402c817bccb6bdc16b24

Figma Desktop App version 102.9
Running on MacMini M1 16GB of RAM memory.

`- - - - - -

One week later update: issue was happening only on a specific file. Pasting the same components shown in the video to other files (in the same Team / Shared Library) didn’t cause the same issues.

My temporary workaround was to move components from old file to new file, in order to avoid the issue reported in this topic. I think I lost some original components in the process, but I believe they’re still accessible through “Restore main component” function.

Hey, I’m having exactly the same problem. I have a couple of files into the same Project in Figma (Figma Pro btw), but when pasting an instance of a component into a new file, it does it incorrectly (icon color changes, nested components with overrides just reset)…

One week later update: issue was happening only on a specific file. Pasting the same components shown in the video to other files (in the same Team / Shared Library) didn’t cause the same issues.

My temporary workaround was to move components from old file to new file, in order to avoid the issue reported in this topic. I think I lost some original components in the process, but I believe they’re still accessible through “Restore main component” function.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.