Figma Support Forum

No unicode support?

I am trying to insert the unicode character ⊢ into a text field in Figma and it does not show up. It only shows whitespace. I found this old post with someone claiming that this should work, but it doesn’t on my end.

I’m on Chrome on Linux on the Figma web version.

You need to select a font which supports this character. If a font doesn’t have it in the charset and Figma’s fallback font which is Noto Sans doesn’t support it either, it won’t show as there is no info on how it should be drawn.

I am using a font that supports it. I know this because it is a google font that I am using on a live website and it renders the character perfectly fine. It does not render on Figma though. Why would it render when live on the web but not on Figma?

Could you tell me the name of this font?

I had a similar issue with a special character for one of my designs. I ended up using the alt code for it in Microsoft Word, then copy paste it into figma and it showed up, then I could just set it to the font I wanted, bit of a work around but not sure why it happens. Once I had it showing in Figma it was all fine.

The font is Source Sans Pro. I also tried with Roboto Slab. Neither work. I tried by inputting the character using Ubuntu’s native unicode input scheme (ctrl+alt+u <unicode_code>) as well as copy&pasting. Neither work.

@Leo_Torres, there are currently only 4 font families on Google Fonts that have the “Right tack” (⊢) glyph:

  1. M PLUS Rounded 1c
  2. M PLUS 1p
  3. STIX Two Math
  4. Overpass Mono

Other fonts don’t have this glyph.

Ah, good catch! In that case, my browser must be using a fallback font that does support it, because I am sure I am using a font not on that list.

Perhaps this fallback scheme could be implemented in Figma at some point!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.