FIXED: Exporting seems to now have a glitch

The export feature in Figma doesn’t seem to be working correctly right now. It’s adding an extra pixel to the export size vs. what my Frame is set to; and if I try to export at 2X the size, it doesn’t size up the export. Just adds an extra pixel to the dimension. This wasn’t happening until just now (I export digital and web assets often).

1 Like

To prevent this from happening, you need to set integer values ​​along the X, Y axes for your frames.


Hello Anne Marie am also struggling to export a desktop design i made do you
how can i make the export and get full code (html,css,javascripts ) i made

I’m having an issue with this as well - the downloaded svg has a different font than I set on Figma and a straight line in the graphic is showing up tilted - not sure what’s going on.

Does anybody have any tips? Is this a Figma issue or am I doing something wrong?

Every time I export assets(PNG) if its not at x0.y0 it adds extra pixel.
I have to move an asset to 0.0 export it from that location and move it back.
I think its a BUG!


-To prevent this from happening, you need to set integer values ​​along the X, Y axes for your frames.-
Can you give us an example?

1 Like

Hi @Leonid_Korostyshevskiy,

Can you confirm that your assets X Y values are set to whole numbers?

1 Like

Guys. Also you have to make sure that child elements in your frame also don’t have float values in coordinates and sizes.

I hope this helps you.

Hello @dvaliao, I have this probably quite often. My asset is set to the right dimension but on export it’ll add a pixel because of the X/Y coordinate are not whole numbers. Sometime they are whole numbers, but a parent element is not.

Do you know if this is a bug and is planned to be fixed? If it’s the intended functionality, could their be a warning that says something about exports being on sub-pixels and it will affect export size?

I can’t tell you how frustrating and time consuming to hand over exported assets and hear back that the size is off and then have to go back into the file and check all X/Y coordinates of every asset and re-export.

@dvaliao @PepperPete

This solved the issue for me >> Loom: Figma adding extra pixel bug (SOLVED)

This is still a problem for me, even after correcting the coordinates to fall on whole numbers. I did find a fix for it. It seems that my object was a frame and the frame had a fill on it, instead of it being a shape object with a fill. Switching to a shape instead fixed the export so it no longer added an extra pixel.

I will also note that I did test out removing auto layout first, before adding a shape with a fill instead of the frame with a fill. And that did not fix the issue for me.

I add fills to frames all the time, especially when using auto layout. I’m surprised I haven’t heard from any of our developers regarding this export issue :slight_smile:

Hope this helps someone else.


I’m sorry but I don’t think setting the frame’s X/Y coordinate to whole numbers should be considered as a solution because like Sarah said, you can be using auto layout and having the frames inside it to be located on numbers with points. When users using your own features that conflict with each other, that is bad UX; and you should fix this and not ask users to adapt to this bad UX.


I got this to work by following the instructions. This is an extremely annoying bug that should be fixed.


I wonder if Figma can automatically snap all frames on canvas to pixel grids, even if user
has turned “snap to pixel grid” off :thinking: because many times it’s simply because the entire screen’s coordinates are not on whole numbers that is affecting all elements in the frame; and the possibility of a screen needing to be put on numbers with point is so little. Or at lease make it easier to turn “snap to pixel grid” on and off; to me putting it inside a drop down menu don’t actually quite make sense in terms of the need of the frequency of use.

Problem still exists. Anyone know the solution? Integer values along the X,Y not helping, specially if you have autolayout


Hey All, thank you for your patience!

Exporting objects with a multiplier applied no longer adds an extra pixel to width and/or height.