Bug: Exporting to PDF adds a random box around my links

The PDF format is universal so it doesn’t matter which OS you use. However if you are experiencing issues with one method, try another one. You can also try to remove commas from the border attribute to see if it has any effect. Or try a different text editor just in case.

Thank you, I tried another text editor and download Notepad++. Now everything works properly :slight_smile:

2 Likes

Thank you for sharing! Just found out about this issue today and Notepad++ is what made it work for me :grinning:

1 Like

Guys, I found a really easy solution to this problem. There’s a free Figma plugin called Pitchdeck which can allow you to add links to frames in your design, then export in pdf format without any issues. I followed the guide of this youtube video

And it worked like magic. :ok_hand:

2 Likes

seriously thats it? figma cant export the most universal format without code hacking. come on guys, lets be professional

3 Likes

wrong, not a client ready solution. doesn’t export all pages at full resolution (very low res on screen ready 200ppi pngs) and no pdf spec before saving. its like whoever designed this plugin and figma has never made a pdf. ahhh ux/ui idiots

2 Likes

Thank you so much. That’s work for me.

Sadly, this work around is not easy when you have at least 20 link in a doc and have multiple versions…

Just export pdf no link from figma.
Then open it with foxit reader and use hightlight (shortkey - T) to select text you want put link. Press RIght mouse => create link => Thickness: 0 => next => paste link => done.

1 Like

THank you so much! It is really helpful!

I put a small visual walkthrough on how to use this Terminal command in Figma community for anyone that isn’t familiar with the command line.

Figma please fix this simple but annoying little thing!

1 Like

Hi friends, if anyone is looking for another option for resolving this, our TinyImage plugin exports compressed PDFs without any outlines around links by default (you can optionally turn them back on in the plugin settings if needed). Hope it helps someone coming across the thread :blush:

1 Like

Thanks :+1:

1 Like