Windows pinch zoom on figma is too fast (HDPI drivers)

Same here, Windows 11 HP Envy 13

This is still an issue. Running windows 10 with an Asus Predator.

I am facing the same issue

it worked. Thanks bro

This comment thread is pretty hilarious. The zoom is absurdly wrong on a track pad and I would prefer to have it turned off compared to how it works now. It would take an intern less than a week to detect windows user, reduce zoom sensititvity, test and deploy. Gives me a headache trying to move my fingers a quarter millimeter otherwise it blows up.

1 Like

hello\ Michael I got the same issue, and I believe it’s the account problem, I don’t have the scrolling problem when using other accounts with the same device…

my email is fathuraldifauzi@gmail.com thank you!

yeah guys, i found a FIX for this!

need to choose — at ONE screen

Hey @poiru, thank you for your efforts to fix this. Almost a year after your last reply, we’re still experiencing this issue. Perhaps you should change the Figma.com home page to say “Figma connects everyone in the design process, as long as they’re on a Mac because we treat Windows users like second-class citizens, so teams can deliver better products, faster.”

And what about yourself, @Michael_Feldstein? Do you care to provide an update on this fix after 3 months of inactivity by any Figma employees? Or should Windows users abandon Figma for a product that meets their basic needs?

“Perhaps requirements should not be prioritized based on quantity of affected users, but on the severity of those effects.”

Unfortunately it only happens to a subset of windows users so if we made that change for every windows user it would break for everyone else (this is what we originally did). We’re trying to find a solution that we can roll out to everyone, its just hard to get our hand on a device that exhibits this particular problem.

Honestly if anyone is in the bay area or detroit we’d come to you (if you have a computer that breaks when the flag gets turned on)

1 Like

Oh wow this is super interesting, i had been assuming its a factor of hardware but maybe its a factor this setting. Thank you for the heads up on this

1 Like

Does Viktor’s comment above about the sensitivity settings solve the issue for you?

1 Like

@Viktor_Sukhomlyn’s comment refers to a Windows setting which changes scrolling speed system-wide and only improves zooming in Figma when using the workaround of CTRL + Scroll. This has nothing to do with the original topic of pinching to zoom. So even if Viktor’s suggestion did work, it only improves an already suboptimal zooming method.

With all due respect, I doubt the statement that “it only happens to a subset of Windows users”. I have tried multiple Windows devices, including running Windows on a Mac and using an Apple Magic Trackpad 2 conected to Windows, yet the issue persists.

After reviewing this thread, several responses mention the Surface Book, Surface Laptop, Surface Pro, HP Omen, HP Spectre, HP Envy, Razer Blade, Samsung Pro Book 360, Lenovo Thinkpad, Lenovo Ideapad, Lenovo Yoga, ASUS VivoBook, ASUS Zephyrus G14, and the Dell Latitude. I’ll add to this the ASUS Zephyrus M16. That is almost every major PC laptop manufacturer. And considering that several users, including myself, are experiencing this issue when using an Apple Magic Trackpad, I can almost guarantee that this is software-related.

Please note that @Viktor_Sukhomlyn’s comment does not address pinching to zoom, only the zooming speed when using CTRL + Scroll to zoom.

2 Likes

Right, we haven’t rolled out the fix to everyone yet because it ends up breaking some people who it used to work properly for.

Our current plan is to roll the change out for everyone, and add a preference to use the old behavior for anyone who this breaks for.

3 Likes

Thanks @Michael_Feldstein - when will this go live?

tomorrow ideally

1 Like

The “Use alternate zoom handling” preference has been shipped, and i will be rolling out the fix to everyone over the course of the day (hopefully). If you find that your trackpad that previously worked is breaking, please try this option (and let us know). This preference will only roll you back to the old behavior, not opt you into the new one, so only use it if you used to work and are no longer working. If you’ve always had the problem please be patient while we roll out the flag.

5 Likes

I’ve rolled out this fix to everyone. If you’re having trouble try turning on the preference mentioned above! If that doesn’t fix it please let me know!

3 Likes

I can confirm that this is working on the ASUS Zephyrus M16. Thank you so much for your help :raised_hands: This will be a huge improvement to touchpad users on Windows!