White vertical lines appearing in prototype/present

Thanks a lot ! @Ankur_Parmar

Also having this issue

Sometimes presentation mode adds a single horizontal or vertical line over particular screens; not every screen in the prototype just certain ones.

My primary questions are, has anyone else run into this? and how do I make it go away?

What I can tell… The line is definitely not an element in design; it’s not an element I’ve added. The position of the line will change depending on the zoom level. Sometimes shutting down and restarting help but other times it doesn’t. I may see the line on my machine but other won’t see it on theirs. I can’t faithfully reproduce it but I think it may have something to do with either components or smart animation.

Any insight would be great.

4 Likes

Yes, this seems to be a persistent bug in Figma. I get strange vertical or horizontal lines that appear only in presentation/prototype mode (not in design mode).

I have a 4K monitor with Windows zoom set to the default 150%, if that makes any difference.

Changing the dimensions of the frame by 1-2px sometimes improves it partly, but sometimes the lines just show up elsewhere.

The issue has also been mentioned here and here but with no resolution.

I’m going to pipe in on this in an effort to add to the numbers and get @anon21722796 to fully address and resolve this topic. I’ve looked through all the forums and appreciate @Ankur_Parmar’s partial solve, but this is something that really needs to be taken care of by Figma itself! Can you fix this issue, Figma?

@Joss_Arete
Yes obviously this doesn’t solve the issue and Figma needs to fix this asap. Figma is unable to render an entire vertical or horizontal set of pixels when the layout is forced to scale and fit inside a particular resolution available on the user’s side.

Absolutely! Thank you for your workaround–and for this explanation as well!
Just adding my voice to the pile of us nudging them to fix this as soon as possible. Part of what makes Figma so great is the ability to share that prototype link–but we need it fully functional.

You need to contact the Figma support team via the bug report form. This is a community-run forum.

Hey all,
I just solved this issue by clicking in Options (on the right top corner) when you click on present button, choose Fill - Scale down or up to fill

6 Likes

Thanks, it also worked for 1440 artboards. :+1:

Having the same problem here!

Same problem here, been happening for months now. Can confirm @Ankur_Parmar 's fix worked for me too. In fact on my 1440px frames I had to reduce rather than increase by 1px. Please fix!

I just made another copy of the frame and deleted the one with lines and the vertical lines are not appearing in the copied frame

1 Like

Hey, Thanks for this :slight_smile:
I was able to clear the lines now by filling the frame.

1 Like


This is a screenshot of the prototype in playback mode in Chrome. There are no lines in design. I need to know how to fix it please.

Hey @Oleksiy_Rebrov,

I moved your new topic to a similar existing topic. Please try the solution listed above, and let us know if it helps.

changing the artboard width didn’t help :frowning:

Sorry to hear that. Do any of the other solutions listed above help?

This problem only exists for prototype in Google Chrome. If I open it in MS Edge eveything works fine.

These 2 suggestions didn’t solve the problem