Figma Support Forum

The entire library have to be published every time now

I have a library that is already published and worked fine since today.
But now even if I haven’t modified anything on it, when I go to the Assets tab (there is no black dot on it btw, so no change), I can see the button “Publish 880 changes” (all the styles, colors, fonts, components of my library).

It’s the same if I make any little change on my library, it seems that the entire library has to be published again…

Thanks for your help! :slight_smile:

Hi @B_A - apologies for the trouble. I think you may have possibly been affected by a bug on our end that’s now been fixed, but to be sure, could you please fill out a support ticket here if you’re still experiencing this issue? https://help.figma.com/hc/en-us/requests/new

Same to me… and also the all kind of Styles doesn’t show up while editing the prototypes.

[UPDATE]
Just fixed the problem. I cleared the cache following the instructions and it worked (for now…).

https://help.figma.com/hc/en-us/articles/360040328553-Can-I-work-offline-with-Figma-#clear-desktop

It seems I found a solution after changing some components:

  • Go back to the original state of my library, without the component changes.
  • Go to the web version of Figma, which finally understands that there are no changes to my file (the Figma application does not).
  • Redo the changes to my components.
  • Publish the library from the web version.
2 Likes

Thanks for the update! Just to confirm: after you published the library from the web (after all other aforementioned steps), the desktop app then seemed to have synced up correctly?

Wanted to make be extra sure there weren’t any lingering problems :grinning_face_with_smiling_eyes:

2 Likes

Yes after this, the desktop app seemed to have correctly synced up :slight_smile:

Maybe it comes after clearing the cache (I tested a lot ^^) as the previous comment said.
With this method:
https://help.figma.com/hc/en-us/articles/360040328553-Can-I-work-offline-with-Figma-#clear-desktop

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.