Figma Support Forum

Swap components drag and drop being finicky?

I use Command+Option to drag and drop assets and replace components a lot, but lately it’s not working like it used to. It seems to work maybe 1 in 10 times. Seems to especially have trouble replacing nested components that always worked fine before. Anyone else experiencing this?

3 Likes

Same here. It usually swaps with the next sub-component in the hierarchy, instead of the deepest one like it used to do. Really hope it’s a bug, not a feature :upside_down_face:

Can no longer drag to swap out component instance (while holding Command+Option)
I’ve always been able to hold Command+Option while dragging a component from the Assets panel over an existing component instance to do a swap. This is no longer working. The Option shortcut (for non-nested instances) also does not work anymore.

Does anyone else experience this?

2 Likes

I also just recognized this… I can get it to work in non-nested instances but infrequently. Feels like more a bug on my end than the removal of feature maybe :man_shrugging:

Figma team is a aware of this bug and it should be fixed soon.

2 Likes

Same here. The only way is to keep moving the mouse above the component, sometimes it works… but it’s tough

Having the same issue here

Is this because I just paid for your plugin you are so responsive :stuck_out_tongue:

1 Like

Support told me a week ago that they were working on it.

Relieved to see others have been having this issue…thought I was going crazy. Glad to hear the Figma team is working on it. Phew!

Figma seems to have fixed it. I no longer have a drag problem.
ezgif-7-5ca27c9bc0b8

I’m not able to swap with command+option anymore either. I use it all the time so this makes me so sad. :frowning:
Update: Actually, I reloaded all my tabs and it seems to be working again! Whew! Thanks Figma!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.