Figma Support Forum

Smart selection acting wonky

I have Smart Selection bars showing up in one of my layouts. They are blocking me from selecting and moving items.

By my understanding, they should only appear if I select a couple of items. I have nothing selected, but they’re showing.

Oddly, they want to connect unrelated items. I have a centered frame inside a parent frame (a web desktop layout within a desktop wide page). Smart Selection is trying to align text in the center frame to the parent frame and won’t let me touch the text.

Is this a bug? If not, how do I turn Smart Selection off?

Thanks,
Radley

Can you show an example where you think it works incorrectly? It’s definitely far from perfect but I haven’t experienced any issues yet.

I placed a copy of the layout here:

It’s the first big block under the top menus named “Header”. When I click on it, the Smart Selection controls immediately show.

Possible trigger: check out the diagram on the right. I scaled it down earlier, and the text frames are too narrow. When I scale it back up, the Smart Selection controls don’t show up.

I see smart selection but how does it prevent you from selecting and moving texts? I still can do it just fine. It appears when you select a group or frame sometimes when it sees that items have consistent spacings inside. And this seems to be the case here, so it’s not a bug.

But your feedback is totally valid, and to share it with the Figma team, feel free to move your topic to #product-feedback and change the name to a suggestion instead of a question since there is no way to disable it currently. Other people with the similar issue will be able to vote for it.

It looks like it was a corner case. I can’t reproduce it now either.

FWIW, I was seeing a wide bar with a negative value. If you move the body text a little, you’ll see it too. It was the wide bar getting in the way, but it seems to be ok.

Thanks for looking into this!

-r