Rubik Font Doesn't Work

Rubik font doesn’t work for me in Figma. It doesn’t work in desktop or web app. I have tried to reinstall the font locally and use different formats but it didn’t solve the issue for me. I also use the Figma font app for web.

Issue: When I select Rubik font in Figma, the font doesn’t change, it stays the same as it was before it has been changed. Every other font works except this one.

Has anyone experienced this problem with Rubik font?

Is there currently any solution to this problem?

Thank you for any suggestions.

I encountered the same problem. but the key point is Figma cannot use variable fonts at the moment. When you download Rubik fonts in google font, you should get a static folder. Use The files in it

GitHub - Tgemayel/variable-fonts-figma: A plugin to run variable fonts in Figma is a plugin that provides a workaround for the lack of Figma VF support

1 Like

I used static fonts and it didn’t work for me :slightly_frowning_face:

1 Like

I also tried using the static font and it still wouldn’t work. :upside_down_face:


Has anyone experienced any bugs using Rubik font in their figma projects? In my case the font fails to show even tho it’s installed locally and I use figma desktop app.

Yes, this font is notorious for not working well with Figma. Try to download it from other resources in order to get a different version and/or install it in other formats (ttf/otf), this might help.

1 Like

I tried to download other formats of the font but it still doesn’t work :frowning:

DId it work for you in the end?

Make sure you are installing a static version, not a variable one.

It doesn’t work on my machine after installing static version, is it possible that figma app still tries to use the font from google fonts instead of local installation?

No, Figma always chooses the local font when possible.

What would you suggest when I installed font from static folder only and it still doesn’t work on both web and desktop app. Maybe I need to try different machine? Is there any other step I need to do after installing static font?

This font is bugged for many people, many fonts are broken when downloaded from Google Fonts. Try to install it from GitHub: GitHub - googlefonts/rubik: Rubik fonts

1 Like

Google Fonts also strips many OpenType features from its CDN-hosted fonts to improve latency.

If you want to make full use of a font’s OpenType features within Figma, you’ll need a local copy of the original font files, not the watered-down CDN font files. Same goes for using these OpenType features in production.