Figma Support Forum

Remove intersection in lower layer only

Hi All,

I am trying to create a new icon, based on an existing icon.

So, what i need is for the intersection of the two icons to be removed in only the lower icon. I’ve tried the Figma options such as Union, Subtract, Exclude, but it doesn’t get me what I want.

And it needs to be transparent (what I made green in the example could be either light or dark bg)

Can anyone help with how to do this in Figma please!

Subtract the rectangle with rounded corners shaped like the small icon from the bottom icon.

Hi Gleb, thanks for the prompt reply.

but, I had already tried Subtract -it doesn’t work. Its results in only the intersection remaining.

Whats i did was select both objects, and then (from the Boolean options above) select Subtract.

Heres, a simplified version. Would be great if you could try it yourself:

What objects did you select? From your screenshots it seems like you tried subtracting the icon itself, and not the rectangle like I said. You need to subtract a solid rectangle. :black_medium_small_square: Don’t touch the smaller icon at all, it shouldn’t be a part of subtract.

I’m a little confused, because, the subtract option doesn’t even appear unless multiple objects are selected.
And when you say a solid rectangle - do you mean, I need to create one? Currently there are no filled-in rectangles (because it needs to be transprent)

  • i added an update to my earlier post just as you were replying

Yes, you need to create one, or use the solid one you created before if you don’t need it. To subtract the rectangle from an icon, select the icon and a rectangle together, the option would appear.

Still not working Im afraid.

I’ve just tried to make the file editable by anyone so I could show you. But the link its giving me is returning a File not Found:

https://www.figma.com/file/FPYDekEUTELNjx7FytDcO0/Subicon?node-id=0%3A1

What else do I need to do to share?

Set access to “Anyone with the link can view”.

Yes, i had already set it to Anyone.
Screen Shot 2021-10-11 at 7.12.46 pm

the modal automatically activate the email field, as if I need to enter peoples email address

Try “can view” instead of “can edit”. Everyone would still be able to duplicate the file.

Also looks like your file is in the Starter team. I don’t think edit links are supported on the Starter plan, only individual invites via email. Not sure why you can even set it to that.

Anyway, here is the example: https://figma.fun/VakqLq

I created another document, and now I can get to share.

would be appreciated if you are able to take a look, and see if you can do it.

thanks

*i removed the filled-in rectangle

Hi @Gleb
thanks for your demo. Yes, it seems that is basically what I’m after. But I’ve tried to replicate it with my icon, but I can’t get the same result. I was thinking that I needed to select both the rear icon and the solid rectangle together and choose Subtract? But it doesn’t work. And also it creates a different type of icon (to your example) in the layers panel, so im not sure whats going wrong:

Here it is:

its ok, ive figured it out now. thank you