Figma Support Forum

Prototypes Lagging Very Badly

Recently my project prototypes have started to lag incredibly and become unusable for presentations. The latest change I can think of is updating my table components into variants.

Granted I have very big projects, but they ran well previously and now even just trying to open an overlay on the very starting screen is impossible. This only started recently, within this week.

I cannot share any videos of this now due to confidentiality. If necessary I would need to blank out some elements. I was wondering if anyone else has the same experience.

8 Likes

Same problem.
Yesterday everything worked fine.
Today it’s lagging.
Simple prototypes work well, but the more complex are lagging badly.

3 Likes

Same here.
In the app it’s lagging
In chrome it’s dead

1 Like

:hear_no_evil:

I have the same issue, it lasts about 2 weeks! It drives me crazy…

1 Like

I’ve also experienced severe lag when running usability testing sessions. Is there a technical issue on figma’s side? I thought it was my participants internet connection.

Yeah. Yesterday it was fine. Today I get hover state on button after 3 sec. holding mouse on it…

2 Likes

Anyone heard anything on this? I have a very important presentation tomorrow and it’s too slow to work right now.

1 Like

Our team is currently taking a closer look at this.

2 Likes

Alright if you refresh now, do the lagging problems go away?

3 Likes

Yep, that did it for me.

Thanks so much!

2 Likes

Yes it seems like it is fixed, thanks for the quick response Figma team and also to the other users who shared their experience.

1 Like

Yes it works great again.
Life makes sense like this :partying_face:
Thanx

1 Like

@Josh For me it’s not good at all
I can DM a prototype link or a screenrecord if needed
can I?
image

Have you tried doing a restart?
When you say “not good at all” does this mean the prototype doesn’t load at all or is it just laggy? Can you provide some more info?

Hi josh
I’ve sent you a screen record via twitter

1 Like

Thanks. Will take a look at this today with the team. In the future if you click on my profile you should see a message button in the top right. This will let you send a PM within the forum. :slight_smile:

1 Like

Today, heavy prototypes can not be loaded again.

  • Hello. Same issue. My desktop prototype works fine when interacting, and the mobile prototype lags and freezes very much. And nothing helps to solve the problem. For some reason, no one from support responds to my topic, although I attached screencasts and a link to the prototype and described the problem in detail. If it is not difficult for you, answer in my topic to draw the attention of support to my problem. This really prevents you from approving the layout with the customer. Thanks. Here is a link to my topic: Prototype is freezing (mobile layout)

Having identical issues. Significant lags in prototypes. And my pages now freeze in several cases.

Am using some interactive components but issues preceded their use. Are there plans to optimize and audit prototype loading performance?