Figma Support Forum

Prototype Error Message "You don't have permission to open this file."

When in prototype i get “You don’t have permission to open this file.” when I want to open the file in Editor.
Apparently, I’m the owner of the file + account.

Have you added a second account to Figma Workspace? Maybe you’re trying to open your file from a second account that doesn’t have permissions?

Nope. Had a second account → removed it. Still getting the same error.
Tried to narrow down the problem. Seems that it occurs only on my team files [Pro plan].
I;m Admin.

When I click on the “open in editor” button in prototype mode, it says that I don’t have access to the file, even though I’m an editor on that file. It even happens to people that are owners of the file, across different files. I already reported the bug, but maybe somebody has answers here? Below is a video showing the problem. Thanks!

1 Like

If you logged out of your personal account from the desktop app, you have to check if it’s still logged in on the browser.

I logged out of my personal account on the desktop app to see if it fixed the problem. I did not. Then I went to the browser and found that it was still logged in. Logging it out from the browser as well and then restarting the app solved the problem.

I hope this helps.

You have to do some clean-up on accounts to get this working…
The steps I followed:

  1. Logged out from second account ( I believe applies if you have >2 accounts).
  2. Closed/Reopened app
  3. Add account on app. (Had some error occured" :frowning: messages on the app but that didn’t stop me.
  4. Opened browser → login
  5. Tried 2-3 times (I even had a session login expired message)
  6. Done!

the problem is back, even though I’m logged in with just one account (the one that has permissions) both in the app and in the browser :confused:

I get the same error - it feels like a bug to me…
I literally have the file editor open next to the prototype but when I click at the top to navigate from the prototype to the editor it tells me I don’t have permission.

same error here

This didn’t work for me. Here’s my step:

  • Update Figma client: no update available – didn’t work
  • Logout/relogin several times – didn’t work
  • Uninstall/reinstall Figma client – didn’t work
  • Uninstall and clean related files/cache – didn’t work
  • Change file permission to “Anyone with the link can view” – worked

However this file should be private and not shared on the internet. I hope this issue could be fixed asap.

Hello Figma team. I met the same issue, I 've tried all the solution above but it dose not work.

This is happening to multiple users on my teams all of a sudden. This definitely feels like a bug.

My team is having similar issues but with the prototype links … Even though permissions are set correctly. We cannot conduct our usability tests due to this. This should be fixed ASAP

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.