Prototype doesn't load on mobile (android) phones

I created a mobile prototype. I selected a device type (iPhone 8) it works fine on the selected device when viewed via presentation link (url of the working prototype when you click the play button).
The very same link takes forever to load on an old samsung device. I thought this may be because I selected iPhone. I then selected ‘android large’ from the device type and again tried to view on the samsung device and it still takes time to load between screens.
Someone suggested not to select any device type (ref. User Testing Prototype Loading Issue - #7 by Evan_Hocking) but I still get the loading issue.
I don’t understand what can be causing the issue as the file size is small.
I also have found that others are experiencing the same issue - prototypes not working on mobile…(Bugs in prototype preview (mobile browser only) *Edited)
Please can anyone shed some light as to why the prototype fails to load on a fairly old android - in google chrome.
Thank you.

This topic was automatically closed after 30 days. New replies are no longer allowed.