Figma Support Forum

Problem with prototype in Behance

Hi!
When viewing my prototype from a link on Behance, the prototype in figma does not load.
The url where the prototype is located is:
https://www.behance.net/gallery/125044261/Vinted-case-study you can find the link by doing ctrl + f and searching for the word “here”

I have seen that the original link in Figma to my prototype is:
https://www.figma.com/proto/VOZ96arFlqvIDDjfw2ELdJ/Tania-Dominguez-Vinted-app-prototype?page-id=173%3A546&node-id=246%3A1211&viewport=611%2C245%2C0.2787569463253021&scaling-down=down point-node-id = 246% 3A1211

However, that same url put in a project on Behance makes a redirection to this other url and that is why the prototype is no longer seen:
https://www.figma.com/proto/VOZ96arFlqvIDDjfw2ELdJ/Tania-Dominguez---Vinted-app-prototype?page-id=173%3A546&node-id=246%3A1211&viewport=611%2C245%2C0.2787569463253021&scaling=scale-down&starting-point-node-id=246%3A1211

This same behavior but in reverse, I have seen it in other Behance projects that included a link to the prototype in figma and the redirection is done correctly. An example would be this:

Where if you do ctrl + f and search for the word “aquí” you can see the link to Figma (initially the url before each% has a 25, clicking on the link opens the url of figma and redirects to the same irl without the 25.

Behance tech support tells me there is nothing they can do as it is not a redirect from you. Can you help me?

Hi @Tania_Dominguez, you can try to remove everything after the “?” character from the URL.

In that case, the prototype is not displayed either and the same error 400 appears in the browser console.:

{error: true, status: 400, message: "Missing required parameter page_id"}
error: true
message: "Missing required parameter page_id"

I can use the original url of the project in Figma without any parameters, but the user would access all the pages that make up the project of the case study and it is not what I want.

Also I just realized that the url of my prototype not only changes when it is included in Behance, it also changes when I write it in this forum (now for example if I visit the link to the prototype in Behance that I had put in this forum, it works correctly, but if you compare that url with the url to which the link to the prototype points from the Behance page it is different.

To expose it in the least confusing way I put the urls as if they were code in this post so that they are not changed:

Initially the url that I put in this forum and that corresponds to the one that Behance puts in the prototype that makes it not work is this:

https://www.figma.com/proto/VOZ96arFlqvIDDjfw2ELdJ/Tania-Dominguez---Vinted-app-prototype?page-id=173%253A546&node-id=246%253A1211&viewport=1051%252C539%252C0.44999998807907104&scaling=scale-down&starting-point-node-id=246%253A1211

By putting it in this forum without putting it as a code block, it has been changed for the original url

https://www.figma.com/proto/VOZ96arFlqvIDDjfw2ELdJ/Tania-Dominguez---Vinted-app-prototype?page-id=173%3A546&node-id=246%3A1211&viewport=611%2C245%2C0.2787569463253021&scaling=scale-down&starting-point-node-id=246%3A1211


I do not understand what is happening, nor do I find similar cases on the internet.

Use this link:

https://www.figma.com/proto/VOZ96arFlqvIDDjfw2ELdJ/Tania-Dominguez---Vinted-app-prototype?page-id=173:546&node-id=246:1211

Hi Yury,
Thank you very much, it has worked correctly for me. I will consider the pattern in the url for future cases of this type.
Regards.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.