Figma Support Forum

Problem with copying text from Microsoft Word

Hi guys,

The last week I have been living with the problem on my mac of copying text from “word” into the text field of figma. If earlier the copied text was pasted without problems, now it is copied as a picture. It only saves copying the text, for example, in the browser field and copying it again from the browser to figma. Maybe someone knows a solution to the problem?


I’ve had this problem in non-figma tools in the past. If you copy without the formatting it should work okay.

I am also having this issue.
What I have been doing is pasting the content into the Notes app then bringing it into Figma.


Me tooooo!!!

I copy it into skype and copy-paste from skype to Figma. But it is really annoyng.


Same issue, it was working fine a few days ago. Pasting the content into the Notes app worked, but it’s not ideal. Thanks for posting the tips though.

1 Like

I am also having this problem. Weirdly enough, only with one Word document. I tried removing all formatting and copy/pasting it into a new document, but still the same issue. Copying it into another app and then Figma works for the time being though.

Has there been and updates on this Figma?

For a work around I’ve been saving the word doc as a text file opening it in Text editor then copying. But this is kind of a pain and adds time.

Is a definite issue on our end. I asked Figma on Twitter on May 20th if this was an intentional change, but no response. Like others, our team has been copying/pasting from TextEdit or transferring to Google Docs, but when you deal with a large volume, this is a huge time suck. Hoping this gets some visibility as a fix would be greatly appreciated.

1 Like

Hey all, can anyone confirm if this is just happening in the desktop app or if it’s also happening in the browser?

Also are you all on windows or mac?

cmd+shift+v may be a slightly easier workaround than a 3rd app (i don’t have word yet to confirm) but this is def not intented.


I also made such a discovery, but it still does not work right away and requires several repetitions to get it in the end

For my teams, both desktop and browser (chrome). both updated to latest versions (figma and chrome). My teams are all on macs

I just discovered this issue too. Experienced it when copying text from Microsoft Word and OneNote. Happened both in browser and desktop app (on a Mac). I am able to successfully copy and paste live text from Apple Notes, HTML, and Microsoft Outlook. My workaround is to either create a plain text file out of the Word document or paste into Apple Notes, copy from there, then paste into Figma.


This seems like such a shocking error to me. How could those at figma not expect one would have to copy text from a word doc. I’m newer to Figma, but really don’t see benefit currently to this over XD (which I already pay for) with quirks like this having me lose tonnes of time. Just seems like such a basic issue that should have been found almost day one in testing.

Cmd + Shift + V (as mentioned above works to paste in text. It was getting very frustrating pasting everything into another app before Figma!

1 Like

wonderful, I was desperate here, it worked for me. Thanks

This is not working for me, I just get a png of the text.

Hi. This should be fixed now – if you paste from Word into a text box, you should see text again. Apologies that this has been broken for a while.

(If you don’t see a change, please refresh your tab.)