Problem Exporting images. Figma says "Downloading images" and keeps there without exporting

Hi,

We’ve rolled out some fixes that should help with these issues and reduce the number of downloads needed for export. You may need a tab reload to pick up the changes. If you have cases where you are seeing exports fail or get stuck in a reproducible way, please reach out to support so we can do further investigation. Thank you for the reports and apologies for these issues.

–John


seeing same issue still

This issues persists for me as well using Figma Desktop App version 116.2.4 released Tuesday July 26.

image

me too, I’m still experiencing this issue today

Our Agency is also experiencing this issue - built in export function does not work, nor do any of the plugins capable of exporting. PDF, JPG, SVG, PNG, nothing.
Like many others before me wrote, it’s stuck on downloading images for hours and nothing happens.

I have the same issue, please fix it.

Can we expect to see additional updates being released sometime next week addressing this issue?

1 Like

Same issue with the export. I also am afraid to restart figma because I get a message that figma is saving changes and my changes will be lost if I quit now. I am just getting this 100% of the time. even if I wait a while.

Same issue with the export!!

Not sure if this would help anyone but I’ve been having the same issue while trying to export a set of artboards into a PDF file. I drilled down into the problem by trying to export each artboard separately to see which one of them is trying to ruin my day.

I found out that some artboards wouldn’t export because it contained components that I pasted in from my other Figma account, meaning that I also didn’t have any permissions to the original file from this account. These components contained some images or even some hidden image elements that were stopping my export. Deleting these image elements, cleaning up image properties and/or detaching instances helped and I managed to export everything successfully.

1 Like

Hi everyone,

If you are still experiencing the issue, it is possible that the code change has not been picked up. Can you try in a fresh browser/desktop tab and see if the issue reproduces? If you are still consistently getting stuck, please contact support and we can help dig into your specific issues.

Thanks,
John

Make sure you guys check if there are any downloading images which are blank images Especially I get these type of images from copying another project .(In the original project, images are directly copied from browser so they don’t appear in my new Figma file). I replaced these blank images and then I can export my work peacefully.

Hey Figma Users,

Recently we found a solution for the Problem of Exporting Images Issue let’s discuss it.

Step 1 - Select the Artboard/Frame the Go to Detach Instance
Step 2 - Select all the frame layers (Which you want to export)
Step 3 - Group it (CTRL + G) then Export the Images, Done

check the video for more reference -

Hi everyone,

We’ve rolled out some additional fixes here (a tab reload may be needed to pick up the changes). Thank you for the reports, and please let us know if you are still seeing problems with this flow.

–John

2 Likes

Hey john,

Thanks for informing, This problem fixed, Try with above solution once , We have faced the same issue and it is solved now - Problem Exporting images. Figma says "Downloading images" and keeps there without exporting - #34 by Fabrx_Design

Thank you John, it finally works with no issues!

Hello, I’m experiencing the same issue and it doesn’t work even when I detach instance and group elements on Figma app. However I can export elements through Figma browser.
Could you please help me to solve my issue, I mostly use Figma app. Thanks a lot!

Hi Noa,

Have you tried reloading the tab or closing and re-opening the tab on the desktop client? It’s possible your tab is not picking up the new code changes.

Thanks!
John