Figma Support Forum

"Preserve scroll position" not working on regular interactions when Beta is turned on

For a specific file I’m working on, I have plenty of interactive components, but also regular interactions between frames. I just recently noticed that when I click one of my regular interactions where “preserve scroll position” is checked, the scroll position is not preserved. When I turn off the Interactive Components beta, the issue goes away.

2 Likes

It also not working in my prototype anymore. Possibly last update

Same here, whenever interactive components with hover states are clicked they automatically send the scroll position to the top, regardless of checking the box or smart animating. Turning off interactive components also works for me.

Hey all - we identified a setting that was causing the issue and this should now be fixed. Refreshing should fix it. Sorry for the inconvenience!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.