Pinch-to-zoom unreliable

same issue

Just ran into this today and it’s happening every 10-15 minutes now. Only fix seems to be to close Figma and reopen it + randomly toggle the zoom/view options.

Fix this… @anon21722796

This has been happening to me for quite a while now. I use the trackpad on Macbook pro. I don’t know if this issue occurs also with a mouse.

  • I try the setting pinch to zoom on and off. — It works
  • Tried quitting figma and opening it again.— It works
  • The most recent one: switching back to chrome or other app and… It works… (after a minute or two).

I Just can’t figure out yet what causes it. And it is SOOOOOO frustrating.
No zoom no design.
@anon21722796

THANK YOU! Yes, macOS Setting → Trackpad → Scroll & Zoom → Uncheck & Recheck “Zoom in or out” worked really well for me. What a pain, but glad you made this suggestion. :+1:

2 Likes

Please fix! Happening several times a day (Macbook Pro M1).

(Uncheck & Recheck “Zoom in or out” in Trackpad system settings did temporarily fix it)

@anon21722796 +1 this is super disruptive to our workflow. Macbook Pro with M1 Pro

2 Likes

+1 I thought I was just having issues with my trackpad :confused:

1 Like

Also experiencing this issue. Going into my Mac settings and disabling/re-enabling Pinch to Zoom fixes it, but it’s really annoying. Would love to have a fix.

Having this issue as well. Very frustrating. Macbook Pro on macOS Monterey

1 Like

I have the same issue, on a Macbook Pro M1. Right now I have a few different browser (Firefox) windows open, and pinch to zoom is working in some of those windows, but not others. It drives me nuts!

i have the same issue.

1 Like

There are few things that make me want to punch my screen as much as this issue. @anon21722796 PLS HALP US

1 Like

Hey all, we have this logged internally and have done some investigating, but as far as we can tell this is a MacOS bug and not limited to Figma. There are a bunch of threads related to this on Apple’s forums and they recommend reaching out to Apple Support

I’ve experienced this bug as well in Figma, Safari, Chrome, and other applications on both my work and personal MacBooks running BigSur and Monterey. It’s super frustrating, and I’m hoping Apple gets to the bottom of this and pushes a fix. In the meantime, we’ll continue to monitor this on the Figma side of things.

If you’re able to consistently produce this within Figma please reach out to our support team via this form here:

Submit a bug form →

Thanks!

The bug is still here, this is becoming extremely annoying, I am thinking of switching back to Sketch. Figma !!! you need to fix this right now. This isn’t some small bug, it directly affects our productivity. So get down right to it please … it’s ridiculous.

And no, it’s not us who should contact apple but you !!!

1 Like

Josh - This happens to me on a daily basis, in Figma only - all other apps, browsers, etc, pinch to zoom in/out works reliably. I use the Figma app on a mac. Figma is the only place the pinch-to-zoom feature stops working. It happens when switching from Figma to the browser or to another app. A few minutes into working in Figma again, the feature starts working again, without my having to restart or mess with settings. This happens somewhat at random but only when switching between Figma and another app or the browser.

I’m also having this issue. It’s not, however, system wide, as it’s specifically only happening to me in Figma while other apps continue to work. Happy to provide whatever I can to help diagnose the issue.

1 Like

Same here on MacBook Air M1 2020 with Figma while other apps work fine. Happy also to provide more details

1 Like

Hey all thanks for continuing to report this. I’m bringing this back up with our team to see if there’s any additional investigating we can do here. Thanks!

1 Like