Pinch-to-zoom unreliable

@John_L how do we share this with you?

This still happens to me. Is there a defacto workaround other than toggling the zoom in and out option for your mac trackpad? I have deleted my Logitech Options app (for my mouse).

this happens to me so much and has been happening for so long that I now just zoom in/out by holding Command and scrolling up or down on the trackpad :sweat_smile:

Hi, this happened to me today after updating to a new MacOS (Ventura 13.2.1). Is there any workaround or fix? This makes the Figma desktop app unusable for me.

Hi Matej,

Thanks for the report. Given the timing with the OS upgrade, it seems like this might be the OS/Apple issue that users have been reporting.

We’re still trying to reliably reproduce it ourselves and provide Apple more information. Unfortunately we have not been able to reproduce this issue ourselves so have been unable to make progress. Here are some other articles/sources that also discuss this issue:


1 Like

Holy crap! It works! This comment should be pinned!!

This issue only happens to me in Figma and has never happened in any other app. The issue happens several times every hour for me in Figma and would definitely stop using Figma at my next company if this problem is not fixed soon.

1 Like

Hey @Brett_von_Halle,

Sorry for the frustration! As mentioned above, we’ve already filed a bug with Apple, as others have reported having the same issue with other products.

That said, our team is proactively monitoring this thread. If you are able to reliably trigger the problem or have noticed patterns when the problem occurs, that would be helpful information for us!

Pinch to zoom is not working after some Figma use.

If you re-enable the trackpad settings (System Preferences > Trackpad > Scroll & Zoom > “Zoom in and out) it is going to be fixed for a while then the same problem will happen again and again.

Mac users need a permanent solution. Please fix that issue!

Mac M1 2020, Ventura 13.2

Super frustrating, only appends in Figma for me. Nothing on Ps nor Miro.

I found that reloading any tab will fix the problem for me, so anytime this happens I just reload one of the tabs that I’m not currently working on.


Just got a 2023 Macbook 16" M2 Max and this is still an issue.

1 Like

This is actually a life saver thank you so much! I hated restarting the app so often because of this issue, and this worked like a charm!

1 Like

Hi there,
only saw closed topics on this, but this is still very much an issue - after updating to OS Monterey I sometimes can’t pinch to zoom on my MacBook Pro trackpad on my desktop Figma app.

Using the trackpad is my main way of working, this is a pretty big impairment for my workflow.

I am running the latest Figma app and latest Monterey OS.

Every now and then, the pinch to zoom simply stops working. Restarting Figma doesn’t help. Then after a while it starts to work again on its own. I can’t figure out if there’s some pattern as to when it stops working.

Figma friends are you experiencing something similar? Has anyone found a way to fix this?


Hi Marija,
There is a post about this issue here.
Unfortunately this is a common issue that Mac users are experiencing with Figma. Until this problem is resolved, what works for me is to disable/enable Pinch to Zoom in the System Preferences, so I keep this tab open just in case the issue occurs.
Hope this helps!


Having the same issue. I’m on an iPad Pro using Figma in Figurative. When I pinch to zoom it scrolls instead of zooms. Pans diagonally to the top left when I pinch to zoom in or out.

1 Like

Facing the same issues multiple times a day is super irriating when you’re between a major task.


This was a lifesaver, thanks so much! Disabling and re-enabling System Preferences > Trackpad > Scroll & Zoom > “Zoom in and out” did the trick!


Thanks disabling and enabling zoom settings solved the issue

1 Like

Still encountering this issue, but that you for flagging the disable/enable fix for the time being!

1 Like