Password protection not available at all

  1. Using admin account
  2. Professional plan
  3. Created project with admin account (AKA I have ‘can edit’ access)

And yet the option to add password protection as outlined in this guide is not available.

Hey there, thank you for reaching out! Could you check, if your file is in your draft?

That did the trick - thank you.