Montserrat Bulgarian Cyrillic Not Displaying Correctly

Hey there,

I’ve been trying to find a solution to this for an hour and can’t seem to resolve it.

I’m making a design for a landing page in Bulgarian. The topic of the difference between Russian and Bulgarian Cyrillic forms is exhaustingly long, so I’ll keep it short with image examples. The issue at hand is that Figma won’t allow me to display the stylistic sets that should come with the Montserrat font.

I’m attaching Imgur links due to the one media file per post for new users limitation:

EDIT nvm apparently I can only attach three links too.
From Local Fonts Eu:

  1. Default Cyrillic vs Bulgarian Cyrillic Comparison Uppercase
    Imgur: The magic of the Internet

  2. Default Cyrillic vs BulgarianCyrillic Lowercase:
    lowercase comparison - Album on Imgur

Now, as for Figma:

  1. Imgur: The magic of the Internet

The stylistic set in Figma is not the custom shapes for different Cyrillic alphabets - it is an entirely separate sister font - Montserrat Alternate. The Alternate typeface definitely hurts my project’s legibility even though it resembles the triangular shapes in the Bulgarian alphabet more than the default. Using the proper shapes is paramount for fine-tuning my designs.

I’ve tried deleting the Montserrat font family from my computer as another topic suggested that Figma prioritizes the local font file over the one from Google → nothing changed

I also tried reinstalling the family and tying again → result

I’m relatively new to Figma, so I think I might be missing something and I need your help.

Thanks!

This topic was automatically closed after 30 days. New replies are no longer allowed.