Modifying Component Resets Overrides on Instances of that Component

I’m having an issue where modifying a component is resetting the overrides that I have applied to instances of that component. The specific modification of the component was the creation of a new variant. The new variant has text that is in a different color than the other variants. Upon publishing the change, my instances that have custom text overrides reverted to the generic text that is used in the component. So the overrides that were lost were on items that were not involved in the modification that was made to the component. Does anyone know why this is happening?

1 Like

@Maurice_Thompson is this still happening? Do the steps outlined in the topic that tank666 linked resolve this for you?

It still happens for me, followed the steps and I still loose my overrides.
Maybe I’m not following the steps correctly or it has to do with the way I’ve nested my components.
I’ve reverted to a previous component and unlinked my variants to go on, but is there any way to keep them linked and up to date?
Josh, sorry to bother, but would you do a more detailed walkthrough if you have the time, you already did a lot with the comment but still not working on my end.
Thanks in advance.

Just making sure that you refreshed first

I tried both steps but when I accept the updates I lose my overrides again. I even reverted to a version from yesterday, then did the steps in the 2nd bullet and lost my overrides again.

I just reverted to a version from 1:47 pm on Jan 19, I then quit Figma and reopened the file, then did the steps in bullet 2 but again my components lost the overrides.

Hmm alright can you reach out directly to support@figma.com. We’ll ideally need to take a look at the files to see why this might still be happening.

If you can reach out and share both the library file and instances file with us, with edit access (please give edit access to support-share@figma.com)

Also if you could point us to the exact instance that’s experiencing the problem and the exact overrides that are lost, that would be super helpful.

Thanks

Unfortunately, I’m unable to share the file as it is company software that is under development.

Hey @Maurice_Thompson It looks like your an Org user so you should be protected by either your MNDA or your MSA, meaning you should be fine to share the file with us, as our data / intellectual property protection measures will be outlined there. If you have further questions though let me know and we can see about connecting with your account manager here.

The steps worked and I’m all set now. I’ve accepted the component updates that previously removed my overrides with no issues. Thanks for the help and ultra-fast responses. It’s much appreciated.

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.