Literally every time I use Figma I see "This web page is using significant memory..."

Every time—literally every time—I use Figma, I see this message from Safari and the page reloads constantly:

I’m a software engineer, I’m not even editing anything, just viewing the designs our designers built. What is going on?

(This is on Safari 15.4 on macOS Monterey 12.3, on an M1 Max MacBook Pro 16" with 32GB of RAM. Please do not suggest the solution is to “use Chrome” because Figma using all the RAM Safari will let it is one thing while Chrome taking over all the RAM on my machine is another. Besides, a web app that only works reliably on one browser isn’t a “web” app is it?)

same, no solution…

Maybe use the desktop app for Mac instead of Safari? Download Figma Desktop Apps, Mobile Apps, and Font Installers

Also, if your designers can re-assign you to the file as a viewer instead of an editor, I think that’ll help with the memory issues. But that is just a guess … but given all the reload issues, I’d at least try and see if that helps.

If I’m a viewer, can I still export assets and drill down into sizes, fonts, colours etc?

The Figma “desktop app” is built on Electron right? So in reality it’s just three instances of Chrome in a trenchcoat, I don’t think that actually solves my problem.

And, apparently, even with the Figma “app” installed, it doesn’t correctly associate links, so clicking a Figma link in tracker opens in my default browser. That’s not very useful.

Yes, as a viewer you can inspect sizes, fonts and colors. To export assets, the designers have to check a box in the share panel to allow viewers to export.

Yes, Electron’s front end is Chromium AFAIK so if that is a deal-breaker I would understand.

Re: Correctly associate links, there is an option in the desktop app to always open links in the desktop app, but given the Chromium concern, I assume that’s a non-starter anyway.

Is there a better place I can report this as a bug?

This topic was automatically closed after 30 days. New replies are no longer allowed.