Figma Support Forum

Layout grid overflowing the top content layer

Hey, how can I fix the fact that layout grids enabled in frames positioned in the background layers overflow the front layers? Non of the layers are locked or fixed on scrolling. Thanks!

Is this popup window nested in the frame which has layout grids enabled?

□ Frame with layout grids (customer information)
⮑ □ Frame with the modal (edit customer information)

If so, that’s expected behavior.

No, it looks like this:

Parent Frame (grids not enabled)
⮑ □ Frame with the modal (edit customer information)
⮑ □ Frame with cards with grids enabled (customer information and 2 more)

So I end up with 3 areas where the grids from the other layers are visible in the top layer. The screenshot shows 1 square on the left and 2 stacked rectangles on the right which mirror the cards dimensions.

Oh, it’s even more interesting. I discovered that one frame controls all the other frames with the grids set. When I toggle the grids visibility of a single frame, all the other are affected too.

I utilize grid styles pulled from the outside library, maybe that information will help?

Thanks!

The behavior you are describing is normal if you used View → Layout Grids setting to turn layout grids off. Once you turn layout grid visibility on for one layer, this setting gets enabled automatically, hence all other layout grids with visibility set to on (eye open) will be turned on. However, since you are using grids from the library, they shouldn’t have individual settings to turn their visibility on/off, so I’m a bit confused about what you are doing.

Regarding the layout grids showing through: I just checked and I can reproduce this behavior. I didn’t know it worked this way. If you think it’s wrong, you can create a feature suggestion here on the forum in #product-ideas category or talk to Figma support team about it via the support request form.
image

Thank you @Gleb, now I know that I’m not the only one. :wink: Yes, I think it shouldn’t work this way as it looks like the grids are set to the front layers which may confuse the devs. And mixes with the top layer grids when they have their own set. I’ll report that, thanks.

No, I’m using the eye toggle in the right panel and it applies to all layers with grids on (even if they have different style applied from that same library):
image