Latest update has made basic prototyping Buggy

I must say I really appreciate most of the Figma updates. However I’ve encountered some frustrating bugs with the Variable update, particularly when it comes to prototyping. One common issue I’ve been facing is with the selected state for menus or tabs. Before the Variable update, this worked reliably, but now it’s become quite unpredictable.

Let’s say I have created a set of tabs, each linked to a different screen. I’ve set up default and hover states for these tabs using mouse enter and leave triggers. Additionally, I’ve defined a selected state, but it’s not connected to the other states within the component.

Say for example, I have five tabs, each corresponding to a screen. In prototype mode, the first tab I select works as expected, I move to the new screen and I see the selected state for that tab . However, after that, it’s a bit of a gamble. When I switch from screen to screen, sometimes none of the tabs show as selected, and other times multiple tabs appear selected simultaneously. This erratic behaviour seems to have no consistent pattern, and it’s really affecting the reliability of this fundamental prototyping feature.

I hope you can get this fixed with the next patch release that might be coming our way in the near future. Please Adobe1 you’re our only hope!! :wink:

1 Like

I’ve had buggy behavior with Prototypes all day. I checked it on mobile thinking my computer had too many tabs open and it was worse. Same on another mobile device.

I keep seeing animated components move immediately from their first to final state and skip their animation entirely. I hope this gets fixed soon.

@Richard_O_Leary,

Hi tank666, I just applied that to one section of my prototype and it seems to have done the trick. Thank you!

I was also really, really frustrated with a pretty simple menu component with some hover states & ‘active’ variants. It was a few hours of struggling to avoid doing some weird workaround.

After some digging, I found my issue - Figma is now default preserving the component state from previous pages as long as the structure of the frame/page is identical. So if you have a page where you’ve changed the components (for example, made a new menu option using the ‘active’ variant); it won’t be recognized because it’s still going to use whatever state was on the previous page.

…if you’re like me and a bit inconsistent with how your frames are structured/named, you may find this means that the behavior is inconsistent and seemingly ignoring how you’ve set up your data. Figma will never tell you that it’s automatically carrying over component state from a previous page, so it’s a nightmare to troubleshoot what the hell is happening.

It gets even more confusing when you’re trying to do the prototyping inside of a Design System, then importing it over to the main file…sometimes the prototype (such as a hover) will come over, other times it won’t.

This topic was automatically closed after 30 days. New replies are no longer allowed.