Figma Support Forum

Interactive components don't work correctly

Hi. Correct me if I’m wrong, but in the current version the interactive components are almost useless. I ran into this problem.

For example, I created a variant as a menu item with different states and combined them using interactive components:

Then I duplicated the menu item component several times to create other menu items. For all of them, I changed the name and icons (which are also in variants) for all of the states.

And this is what happened when I tried to test the hover state for the second menu item via Present feature - the icon and the number on the right changes to what it was in the main component. What is the point of this?

Here’s how it works in XD. I have one main component there too with a specific icon, text, and number. And it’s also combined with states:

When I make a duplicate of that component and change the text, icon and number in it, then in the prototype view everything works correctly - when I hover/click on duplicate component, the icon, text and number are what’s in that duplicate, not what was in the main component:

Here’s how it should work in Figma. The way it works in Figma right now makes no sense. I’ll be glad if it turns out I’m wrong somewhere, but that’s the way it seems.

P.S. Sorry I’m using Google Drive for images, I can’t upload more than one image here directly. You also need to remove the spaces in the links, because I can’t add links.

1 Like

It is hard to troubleshoot without seeing the layer names for each of your variants, but it’s important that they all retain identical names and layer hierarchy so that the proper swapping occurs.

Of course, that’s how I did it, but nothing still works - when I hover over or click on a duplicate component with a changed icon, counter and name - the icon and counter are replaced by those in the main component.

So, no one knows the answer?