Interactions options in prototype

Hi,

I’m learning Figma by following videos tutorials online and i realised my figma do not have the same options and labels as the tutorials. Even not so old tutorials (5months old).

In the prototype tab, my default interaction is “on tap” while the tutorials have “on click”. But i also don’t have the behaviour “change to”… and i can’t do what most tutorials teaches because my options don’t behave as same as the one in the videos.

image

But looking at the released notes i didn’t see anything about that, so i’m wondering why my figma is missing those options. Is it because i’m using a free account ? Or do i need to instal a plugging ?

Thanks in advance, it’s really frustrating to struggles to follow tutorials from the brand youtube chanel while trying to learn the software.

You have a mobile device in the prototype settings, so “tap” is displayed.
Changes to - see tutorials on components and variants. This feature is available for components.

Thanks ! I’ve got the "on click now. But i still have the “change to” greyed out.

Hi @Yann_Trolong ,

The “Change to” interaction only applies to component variants, make sure that you have your variants set up first

More info here: Create interactive components with variants and here: Create and use variants

I hope that solves your issue :slight_smile:

Aaah ! I watched videos about variants but i didn’t realise this was linked to the “change to” option in prototype ! Thanks a lot !

No problem, happy to help :slight_smile:
You are right, it is difficult to know that they are related. I think Figma should change the wording so it makes more sense, perhaps “Change variant” , “Change to (variant)” or similar.