Installed Fonts not working in Figma Desktop App

Same issue. i was able to resolve it before by using the Font Installer and reinstalling the fonts, rebooting etc. But now it has suddenly returned again (I suspect after my OS updated) and the previous solve I used is no longer working.

Have had to revert to another Google font for the time being but it’s not ideal.

Same issue here - I’m using the Desktop app and have successfully used Adobe Fonts with it for over a year. This week, I have seen the missing fonts error not just for Adobe Fonts but also with fonts that are locally installed on my machine. I’ve restarted Figma, restarted my computer, uninstalled and reinstalled fonts… this is kind of a mess. Occasionally, I can get it working only to see the error reappear the next day. This is a little like having to jiggle the toilet handle… hoping that they can get things working correctly.

1 Like

This requires immediate attention. Previous patch solutions are not working as often. I cannot continue asking everyone try re-installing. Please resolve this bug asap. All our projects are halted.

Also having this problem. This is an emergency please fix ASAP

1 Like

+1. This is a problem that shouldn’t keep coming back. I will often have to stop gap by creating outlines of text in Illustrator and pasting them as SVGs back into Figma.

I just uninstalled the Desktop app on MacOS, and reinstalled. It works for me again. I am on Sonoma (14.0 [Build 23A344]). When uninstalling, make sure you use something like AppCleaner which should scoop up all system dependencies (.plist files, etc) so you get a “real” fresh install.

I’ve had luck with this a few times. But I keep having to do it.

Please resolve this issue, this is really urgent.

1 Like

Same problem here, font on Mac is installed correctly, restarted Figma - did not help…

Same problem, I’m suffering :frowning:

I just found a ‘bug’ thread for a very similar sounding problem to this on the forum too - you can follow the action here.

Anyone know if it’s possible to change this posts category from ‘Ask the community’ to ‘Bug’ or tag it that way?

1 Like

Please fix :weary:

Ya this is v frustrating. I’ve tried everything to get Figma to recognize my font’s I’ve installed on Windows and Figma just will not show them and I can’t complete this project until I can use the correct brand fonts. This is bad. Needs to be fixed pronto.

1 Like

Hi all,

It seems odd. Could you try these steps below if the problem still persists? It might be repeating that Céline said,

  1. https://help.figma.com/hc/en-us/articles/360039956994
  2. https://help.figma.com/hc/en-us/articles/360039956894-Add-a-font-to-Figma-design
  3. If you’re still experiencing problems, please submit a bug report so we can investigate: here

Thanks,
Toku

Hello everyone windows 10 user here,
I’m also facing an issue with some weights not appearing.
I tried everything for hours (system cache, Figma agent, reinstall, restarts, differents browser, Figma app…).

The same font worked on another computer. Seems to be machine related.
Finally downloading the font from a different source worked for me. The original one downloaded from the foundry website had issues on my computer.
It doesn’t resolve the main problem as it can still occur with many fonts. Figma team should work on this.

Hi there,

Thanks for flagging. It looks like you did troubleshooting a lot. So, could you reach out directly to the support team with a copy of your file: https://help.figma.com/hc/en-us/requests/new?

Please make sure you use the email associated with your Figma account, include links to the file in question, and share access with support-share@figma.com. Don’t worry, inviting us to view your file won’t impact your billing.

Thanks,
Toku

Hello, solved with the support team,
getting the fonts “install for everyone” with admin access solved the issue

Thanks

1 Like

Alright folks, I might have an actual solution (if the bug source is the same).

Don’t know how many of you running into this problem are using multiple user accounts. I myself am running Figma desktop app on Mac, with a Personal and a Work user accounts.
It seems that whichever account is logged in first, Figma is loading that user’s fonts (User/Library/Fonts), regardless of which user the app is being launched from. E.g.:

  1. Log on User_A first, then log on User_B
  2. Launch Figma Desktop app from User_B
  3. Figma is loading User_A/Library/Fonts, instead of User_B/Library/Fonts

I noticed the fonts that kept being marked as missing, are the ones only installed in my work user account. I just installed these fonts also on my personal account and upon relaunch, Figma is now loading everything with no issues.

You can launch FontBook from each user account to check for any discrepancy, or use Finder:

  • User_A/Library/Fonts
  • User_B/Library/Fonts

(You should be able to copy paste easily in between folders. If you cannot see the Library, it is most likely hidden. You can view hidden folders by pressing: Cmd+Shift+.)

Hope this helps in saving some headaches, and lead to a faster bug patch!
—a

2 Likes

I think they solved the bug. For me, all the fonts are working fine now.

This worked, I just made both folders with the same fonts. THanks a lot!!!

JUST FOUND A SOLUTION. (If you’re on Org Plan tho) Feels stupidly simple that i hadn’t stumbled upon this earlier but nevertheless :sweat_smile:

Admin can add the otf/ttf files manually as an organisation wide resource. Therefore enabling anyone in the org to have access to the font.

I uploaded the font files as admin via the Desktop app on Mac (see screenshot below) and reloaded all my projects and file tabs experiencing the issue, and was pleasantly surprised to see it had solved the issue, not only for me, but for my fellow colleagues experiencing the problem too.

I really hope this helps others experiencing this.

1 Like

This seems like a good workaround but unfortunately I have a Teams plan and don’t see this Resources tab. Local fonts haven’t been working for me since Thursday last week - it’s so annoying.