Figma Support Forum

Incorrect ligature autofixing in the text layer

While trying to type ‘notification’ in the text layer, Figma merges it to ‘notfication’:
bug

Hi @Vlad_Averin, can you tell me which font you are using? For example, this doesn’t happen with Roboto.

It’s a Lato font:

Thanks for the answer. I tried to repeat from my side, but I was unable to achieve this effect.

Have you tried reloading the tab/app? Are you using apps like Punto Switcher, Birman typographic layout, or something similar?

:warning: NOT A SOLUTION :warning:

Hello @Vlad_Averin! I created a text box, styled with Lato, and I could also replicate the issue you are experiencing. There is a way to fix this! :slightly_smiling_face:

Under your ‘Text’ panel, select the 3 dots in the lower right-hand corner. This opens a plethora of other text modification options, one of which is ligatures. That setting is located near the bottom of the dialog box. See below for more details. :arrow_down:

Your video shows that everything is working as expected. You don’t have a bug.

The author shows on the gif that the letter “i” (the 4 character from the left) jumps over the ligature “fi”.

@tank666 - Ah, thanks for catching that! @Vlad_Averin, I went back through and checked again with all of the different stylistic operators, and it appears that I cannot recreate the problem you are running into… at this point, your guess is as good as any of ours.

Upon completing a Google search, it appears that this bug may not be exclusive to Figma. Something about the font causes the unicode to map incorrectly, or something of that effect—I am not a type designer or expert, so I won’t comment authoritatively on that…

I hope you can resolve the issue!

Best,
Micah

Yep, I reloaded Tab, Figma, Computer :slightly_smiling_face:
Stays the same, and not only for me but for my team members as well.
I don’t use apps like Punto Switcher or any typographic layout.

I also tried to create a separate text layer with the same wording and it works fine :man_shrugging:

Looks like it’s somehow interconnected with OS type styles rendering.

And if you copy the text layer to a new file, the problem remains? It would be interesting to take a look.

The problem remains even if I copy the text layer.
Feel free to try by yourself: Figma

Hi @Vlad_Averin, I found the reason. The null (first) character on the line is “Hebrew point sin dot” (U+05C2), which causes this to happen. It is in front of the letter “T”. By removing it, everything will work as it should.

:frowning_face_with_open_mouth:

Nice catch, thank you!