Image fills disappear when merging

Whenever I drop screenshots into my branch file and then merge the branch all my image fills disappear. The frames, groups and images are all still there, but the image itself is not visible and image fills disappear. If you check the archived branch the images are still there. As a workaround I tried copying from the brand and pasting into the main file but they paste without the image fill .

4 Likes

Hey @Jared_Long - this might be best to submit to our support team directly.

Please reach out them here: https://help.figma.com/hc/en-us/requests/new

If you are able, please include links to the main file(s) and any branches you’ve worked on when noticing the image fills disappear. That way, they can try to replicate the issue.

1.Some images in the frame are lost when merge branch to master。

Thank you for this question! I’m having the same problem - and use a lot of image fills. Watching…

Support let me know that they are aware of the problem and they are working on a solution. It didn’t work at first but now I am able to copy images from my branch and past them back into the main as a temporary solution.

2 Likes

I have the same issue, existing screens merged will cause the image in the existing screen gone. Please fix this bug!

1 Like

Still an issue for me as well! Many of my avatar placeholder image fills are disappearing on merge.

Same issue here :raising_hand_woman:t2: all the screenshots disappear but frames remain.

Same issue here. Every screenshot disappears.

Same here ! Our Organization members are now afraid to merge anything :fearful:

Same issue here! all the screenshots are gone but the frames are there

Hi, Engineer on the team here. This should be fixed going forward - merging branches with new image fills should carry over to the main file. If you have existing files that were previously broken due to this issue, we have an experimental tool that we can run to fix those images. Will reach out to you all individually via DM.

4 Likes

Could you share this plugin/work around? We are having similar issues.

Hi Hannah, this is Kiko, an engineer on the team. We recently pushed a fix for this issue and I wanted to make sure it fixed your issue as well. I sent you a DM for more information. Thank you!

Still experiencing this issue today. Checked and I’m on the latest version of Figma. Tried reloading the app but no luck. Had to copy images from original branch. P.s. these were branches made today, not old branches.

Same issue here. File created yesterday-- images seem to appear fine when creating new branch from main, but not the other way around (two branches created this morning both ‘lost’ images on the way back to Main.

I’m still experiencing this issue.

1 Like

This problem seemed like it was fixed but I’m having it again as of a few weeks ago. Only workaround I’ve found is to use image fills on frames. You can just wrap your image in a frame, then copy style of the image and paste style onto the frame to create an image fill. The image fill on the frame survives merging but not image layers.

1 Like