Figma Support Forum

How to make Presentation View render a transparent <canvas>?

I can create a frame with a transparent background and export it without any background color. However, if I go to Presentation View, the background is rendered as black by default.

In the HTML of the Presentation View page, the frame is contained as a . WebGL canvases default to being transparent. Is there another setting that I need to enable to get the Presentation View to not show black?

The closest help I can find is the help Figma page titled “Present designs and prototypes” (new users can’t post links).

G. Figma will present the device against the Background Color you selected"

This doesn’t mention that transparency is not supported.

Go to the Prototype tab in the right panel, there you will see prototype background color setting.

1 Like

Actually, on second investigation, the background doesn’t actually show as transparent (I was bamboozed by how I have my project set up that I thought it was working at first).

The background still renders non-transparently (as white) while I have Prototype > Background set to 100% opacity.


I went into Dev Tools to show that when I have the background of the webpage set to #CCCCCC, the canvas is rendered with an opaque white bg.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.