Figma Support Forum

How to activate gpu in desktop app

I found manuals for enabling the gpu in all browser, but how do I activate in the standalone (electron) app?

1 Like

Thanks for that one and sorry for not being clear.
I was asking (myelf) if I could force an app to us the internal GPU over CPU, my CPU is in full throttle with all teh web-apps like Miro, Figma, Drive, Asana, … and my GPU idling around. Was wondering how to change that.

If you have an eGPU:
On every app, go to Finder, Show Info, and then tick “Prefer External GPU”.
That will force them to use the GPU.

If you have a Mac with two graphics cards:
Try unchecking “Automatic graphics switching”

Note that some apps still will use a lot of CPU, i.e. Zoom

Thanks again for all your time, I still have no external nor two internal GPUs. Just one CPU (Intel Core i5-7360U 2300 MHz) running at around 80-90% all the time and one GPU idling at 0%. Wondering how to force Figma to use the GPU (Intel Iris Plus Graphics 640) at all.

GPU idling at 0%

Interesting, so if you leave Activity Monitor open and use Figma, it shows the GPU at 0%?

When I run Figma in my internal GPU (same one, an Intel iris), I see it varies its usage from 0 to about 10-15% maybe more.

Try opening in Activity Monitor > GPU monitor:

and see if GPU activity changes when using Figma.

Just checked. The process “Figma Helper” indeed sometimes kicks the GPU to 15% and “Figma Helper (GPU)” ist at around 17 as well, but still the CPU does all the work most of the time and the GPU (I am using an app called Stats) is idling at 0-2.1%… I am nevertheless wondering, why its not more balanced.

Hard to say.
Browsers are resource hungry. And since Figma is basically a Chrome browser, that’s why the high CPU usage.

I’m having this exact issue, making any plugins completely useless, but files otherwise are fine as long as I don’t use any GIFs

@Emil3 do this too:

@Apple: I dont have an external GPU so the option isnt even available in the settings you’re referring to