Fonts not updating, ligatures not working

Went to use FontAwesome Pro and none of the ligatures are working

They’re also not working on other fonts

I’ve also uninstalled a bunch of fonts but they’re still showing up in Figma, even after restarting the app and the computer.

Happening no MacOS desktop app and web app. Other desktop apps correctly show ligatures and update the font list.

From browsing the forum it looks like font issues are a common occurrence without much relief. Any ideas here?

Try following the Help Center suggestions in these articles:

1 Like

tried them all.

  • ligatures turned on in the font details
  • i’m the only editor on this file
  • cleared caches

nothing worked.

I just went into a shared library and fixed missing fonts in there and the ligatures now work in my other files – though notably none of the fonts I updated in the library were the fonts I was having issues with.

Figma still shows a bunch of fonts as available that I have removed from my system, but the main issue blocking me has been fixed.

If anyone finds this and is trying to troubleshoot font issues, check that linked libraries don’t have any missing fonts, it might get you through the day.