Fonts no longer working?

I’ve been using Instrument Sans and Instrument Serif for a while now and until recently its no longer working. I have the fonts installed in my fontbook and I’ve reinstalled them a few times. Anyone else run into this issue recently?

Hey Kawaun, thank you for reaching out! Could you confirm that you’re seeing Missing font warning? If so, you’ll see this warning when you need to Manage Missing Fonts.

As stated there the most common reasons for missing fonts are:

  • Missing installed fonts:collaborators are using a local font, which you don’t have installed.
  • Conflicting versions: collaborators are using a different (older or newer) version of the font.
  • Missing font styles: Either the style was missing from a download, or you are using a different version of the font which doesn’t include that weight or style.

If you have this font already installed on your computer, you’ll need to either use our Desktop App or follow the instructions to Access local fonts on your computer to use local fonts in the browser.

If you’ve followed these instructions and are using the Desktop App, or seeing the notification that Local Fonts are enabled on your Figma account settings in the browser, then it’s possible that the font you have installed is not the same version as the one used in the File. To resolve this, we suggest you ask the File’s creator to send over the Font version used to create the File. Once you install this version, you’ll need to restart Figma to serve that version.

Alternately, if you want to use the version stored on your computer you can to select the correct weight in the toggle of that Missing Fonts warning menu. Please note this changes the font version for all editors on the File and so can generate the same error for any other editors who have a different version installed.

Please let me know if you have any other questions!

Hi, so i have the fonts installed on my macbook locally. It should appear under the fonts “installed by you” but i’m not seeing the fonts that i’ve installed in this list in Figma. thanks for the help!

If you don’t mind I can create a support ticket and our technical quality team can help you further. Would you like me to create a ticket on your behalf?

I’m having this same problem, except on my iPad Pro - my MacBook has the fonts I’ve installed. Weird!

Hey Crystal, I’d recommend here as well to reach out to our support team. They can investigate further.

1 Like

Hi Gayani,
I have totally the same issue on my desktop Mac Figma app as well as on the web version (with Figma font helper). Neither reinstalling fonts nor reinstalling the Figma app didn’t help. Figma just doesn’t recognise any font installed by me, however, everything was fine nearly 6months earlier and I was able to use my installed fonts. Please, help me

Hi @Ira_Tokarchuk, Thanks for reaching out! On behalf of Gayani, I’m here for help!

If you’ve followed all the above instructions Gayani mentioned and are using the Desktop App, or seeing the notification that Local Fonts are enabled on your Figma account settings in the browser, then it’s possible that the font you have installed is not the same version as the one used in the File.
To resolve this, we suggest you ask the File’s creator to send over the Font version used to create the File. Once you install this version, you’ll need to restart Figma to serve that version.

Alternately, if you want to use the version stored on your computer you can to select the correct weight in the toggle of that Missing Fonts warning menu. Please note this changes the font version for all editors on the File and so can generate the same error for any other editors who have a different version installed.

If none of these help, can you please try and use these fonts (listed in the Missing Fonts modal) in a new file, in the Desktop app? This confirms that Figma can access fonts in your system font folder.

If you’re not able to access it there, please reach out our support team directly here: https://help.figma.com/hc/en-us/requests/new?ticket_form_id=360001744374
Please make sure to use your Figma account email, attach the screenshots showing the folder the font is installed in, and where you’d expect to see it in your font picker in Figma.

Thank you!

hi! thanks for your response, but the recommendations above didn’t help me to solve the issue. Somehow Figma can’t see any fonts installed by me. A couple of months ago I didn’t have this issue, and created those files with the screenshot above
Will reach to the support team then

1 Like