Fonts Disappeared

Hey People, Relatively new on Figma…

Just opened Figma, on safari web browser, after a few days and found that i cannot use the Text Tool. When i use it nothing types. I can make the text box and it’s recognised in the layers but no typing (screenshot below). Cannot add a stroke to the text box either.

I think ive understood it to be because all my fonts have disappeared?! Not sure why. These are default fonts that Figma has, not my own downloaded fonts.

I can see the text boxes and the fonts on all my projects, with the font names, but cannot edit them or start a new text box.

After searching the Community, seems its happened to someone before and was advised to download the Font Installer (Figma Downloads | Web Design App for Desktops & Mobile) which i have and still not working.

Restarted my MacBook, closed all tabs, refreshed the page, started a new file etc still not working.

Would appreciate any help…

Hey @IamAmir – sorry if my eyes missed this, but is this happening on both the Figma desktop app and Figma on the web browser? Or is it just the desktop app?

You mentioned the font installer isn’t working – did you hit any error messages, or were you able to get the fonts added, but they’re still not appearing?

Can you post a screen recording when you try to use the app installer? I can take a look to see if I can spot any issues.