Figma Support Forum

Font problem

Hi Everyone,
How are you ?
I got a problem, I can’t use the font Spartan or partially. I check in the help center “Manage missing font” but I still have the same problem. I used spartan in Figma before installing on my Mac. I installed and desinstalled the font but nothing change. I need some advice please.

Have a good day

12 Likes

Same here! I simply shut down my computer and when I opened figma, it greeted with a message that says my fonts are missing. But they worked like 8 hours ago.

11 Likes

Having the same problem. Double checked that the local font is installed properly, which it is. Figma is flagging all my files with missing fonts and the replacement option is not working. This is a huge problem that just started out of nowhere. I did recently download the interactive beta - not sure if that has anything to do with it. Please help!

6 Likes

Same here. Had Sofia Pro specifically working even this morning and within a few hours getting the error message it’s now missing.

Some of the other fonts are working but majority are giving the error message

2 Likes

@Velga @Kervee_Quinto @Kate_Valdes @Ken_Kleiner you all need to report this bug to Figma support team via support@figma.com or the support request form.

The same issue, even the standard Arial is reported as missing and needs to be replaced. Seems like something is broken

3 Likes

Seems like I solved this issue by simply selecting a different font in the font replacement dialog and then switching back to the original one. After that Figma will ask you to publish changes if you had those fonts assigned to your font styles → Publish.

1 Like

Thanks, @Gleb. I reported it. Just check and it seems to be resolved :slight_smile:

Hi everyone,
I send a mail at support@figma.com, I’m gonna cut and paste what he sent me.
but this work for me I delete the font in my computer ( because is a google font) and download font installer (Download Figma Desktop Apps, Mobile Apps, and Font Installers)

I hope it’s gonna help you.
Have a good day

  1. Is font missing in both the Desktop and browser version of Figma? Which browsers have you tried loading the app on? Do you have the font helper installed? (you can install it here: ;Download Figma Desktop Apps, Mobile Apps, and Font Installers)

  2. Is this font missing in all files or a particular file?

  3. Make sure all other collaborators with access to the file have the same font version installed. Alternatively, you can have all Editors remove these Fonts if they are locally installed, and then download them from one common source. If the font in question is a Google font, we suggest that all Editors remove their local versions to see if that resolves the problem.

If this is affecting Component appearance you can then use the ‘Regenerate all Instances’ tool from the Search menu to refresh the appearance of all of your Instances at the same time. If it is affecting text or Style appearance or settings outside of Components you can use ‘Select all with same Font’ and then ‘Recompute Text Layout in Selection’.

Let me know if you have any questions, or continue to have trouble after updating those fonts and I’ll be happy to help! Please share screenshots of the missing font or a screen-recording of what happens when you to try select this font.

4 Likes

This just happened to me and I reloaded my tabs and all of my fonts came back. Easy fix

1 Like

Didn’t work for me

Help! I have the same issue, suddenly 2 fontweights were reported missing, I had to replace them with the exact same font & now all my components that used those fontweight are no longer linked to their style…?? :s

1 Like

This topic was automatically closed after 12 days. New replies are no longer allowed.