Fix Outline Stroke

you are right, I just tried and it worked perfectly, I increased the size of the icon and then converted. Thanks

I frequently encounter this problem with strokes set to “middle” or “inside”.
I can’t really figure out an universal way of preventing those crazy straight lines, sometimes deleting them manually does the trick, sometimes it destroyed the whole outlined path. Scaling helps, but sometimes isn’t enough.
I’ll leave you with a case from this morning, took me 30 minutes to do something that should work with a click:


1 Like

Having the same issue with no matter how simple the lines are. It feels it gets worse when adobe bough it

Keep this thing alive

1 Like

Maybe it’s not the best but it works for me, I converted the icon in outlines in this web and then I used it in Figma, I hope it works for you.

https://iconly.io/tools/svg-convert-stroke-to-fill

1 Like

How can this still not be addressed ? 2024 and I STILL HAVE THE SAME ISSUE. with simple shapes.

1 Like

This bug is bugging me! Found no other workaround than simply NOT use the “outline stroke” action in Figma. I have to do it in Illustrator beforehand :frowning:

3 Likes

Unfortuately this issue is still an issue. The workaround by upscaling it 100x and then outlining the strokes works. But quite tedious. Just keeping this post alive!

This long lasting bug is so frustrating. We spent hours over hours looking for a solution or a workaround. Not even the upscaling to 100x is helping. We have to copy every icon to Illustrator to have it outlined.

3 Likes

I just use InkScape when Figma cannot do some vector thing.

1 Like

A tad bit tedious, but I found a SOLUTION using two free plugins that works with intercrossing strokes and actually flattens the shape properly. Not sure if anyone found this or a better solution, though, there’s no way I’ll read all of that above.

The example path I’m using is so complex using “Outline Stroke” doesn’t just tangle the shape, it straight up makes it disappear. Here’s the workaround.

First, separate the path to segments with the plugin “Split Vectors” by our first king Neil Akhmetov. This will create a crap ton of simple lines that can handle the conversion.

WARNING! Pay attention to the stroke thickness. If your stroke was originally set to inside, you will have to take that into consideration whilst setting up potential new values to fix the disappearance.

Now you can select all the lines and click “Outline Stroke”.

As you can see, the overlapping strokes show what you would get in a best case scenario if these were flattened as one. Lots of unnecessary lines within the shape. This is not the best case scenario, as using “Flatten” on this mass will make the whole thing disappear, not just making it unnecessarily complicated.

Now, use the plugin “Really Flatten Vectors” by our second king Steven La. With this, those undesired lines will also disappear.

WARNING! If your shape is as complex as mine, be sure to flatten them in smaller segments before flattening the whole thing to avoid tangling up the shapes or making it disappear.

There you go! Not the most ideal solution, but we work with what we have. You are most welcome to worship me now. Comment if you stumble upon an issue while using this method, though, maybe there is something I’m missing. Good luck, people~ :purple_heart:

Maybe try to put all objects in an auto-layout, and select all of them when doing the steps. If some fail, take them out and do them seperately.

This works for some. The method doesn’t involve third party plugins:

Any news? I’m working with a design system and there’s a shit ton of icons I need to flatten. Why does this have to be so complex?

Still an issue…