Figma Zooms in and out too fast on Microsoft Windows PC

I have looked up existing topics on this issue and tried the suggested fix, all to no avail.

My device is Microsoft Laptop Studio 2, i have tried all available settings, but while using my Figma with my touchpad, it zooms in and out at a weird fast speed. Zoom works perfectly when i use my mouse (MX Master 3S).

I have exhausted all options i can find online, but it still doesn’t work, can you look into this pls?

Hey Christian,
Thanks for raising the issue! As the workaround doesn’t work on your device, would you mind reaching out directly to the technical team, so they can investigate further? Please fill out this form directly here: https://help.figma.com/hc/en-us/requests/new Thank you!

Hi Celine,

Thanks, i will do so.

1 Like