Figma Variant Components Don't Work

Hi everyone

I tried to find a similar topic here but I couldn’t.

I have recently started a new project in Figma based on my other mockup-of-the-mockup project. In the original one (mockup) everything seems to be working fine, however when I try to add variant interactions in the new file they just don’t work in the prototype mode.

I even watched some basic tutorials to make sure I am doing everything alright and it seems that way. I tried groupping/ungroupping objects within the component, using a single shape as a main component and variants, I tried Figma in the browser as well as desktop, I tried checking and unchecking “enable interactive components” and I use a new prototype window every time.

After all that I thought I will start another project and copy elements into it, but it’s still not working. I even went through all the steps once again to make sure I am not missing anything.

Does anyone have any ideas what this could be about? I just don’t seem to be able to make my variants work. Btw, when I try “Navigate to” it works.

Thank you