Figma unbearably slow after fetching library update

Since a few months, whenever I publish a component update from the library file and I fetch it in the design file, Figma has a really hard time updating the components in the design file. Clicking on an element shows a second delay, and when panning the screen everything is jittery. It’s unworkable. And the best thing is that Figma doesn’t get out of this state anymore, I tried to just leave it for an hour, but when I came back it was all the same. The only solution is to restart Figma… When I quit Figma a popup shows that unsaved changed will be lost, which I accept, and then when it restarts the component update came through and Figma is smooth again.

2 Likes

Hey @Dave_Kok, sorry to hear this is happening!

Are you noticing this slow performance when working in the desktop app or browser version of Figma? Do you happen to notice any improvement if you switch between the two?

Also, is this impacting one specific file or multiple files?

I thought a widget in the file was causing it, but it wasn’t. The problem does not occur in the browser version of Figma. It does need a minute or 2 to fetch the component update, probably because it’s used a lot (table cell), but after that Figma runs smooth again. In the desktop version it’s still stuck forever though.

As far as I know it’s only happening in this file. At least my colleagues don’t have the same issue.

Hey @Dave_Kok, thanks for confirming this.

Could you please let me know if your desktop app is running on macOS 11 or later and for Windows it must be running Windows 10 or later in a 64-bit environment?

I’d recommend clearing your desktop cache by following these steps: Clear desktop app cache

Also, are you’re receiving any Memory usage alerts? If you are, I’d suggest taking a look at the following Help Center article Tips for reducing memory.

Please let me know if clearing the desktop cache resolves the issue, happy to help further!

I’m running Figma on MacOS 14.2.1. I’m not getting memory usage alerts, but I’ll try to clear the desktop app cache and see if that works. Will let you know.

Update: I cleared the desktop app cache but it makes no difference. Figma still performs terribly after fetching an update for a component that is used quite a lot. The only fix is to restart Figma.

Hey @Dave_Kok, thanks for the update! Can you please confirm if the issue has been resolved for you completely after the restart? Or do you occasionally still have issues? If that’s the case, I can submit a support ticket on your behalf, so our technical quality team can investigate further.

Thank you,
Gayani

Still have issues. Restarting Figma makes it workable again, but after I fetch another component update I have to restart again. I often restart 30 times a day now…

Hey @Dave_Kok ,
Sorry to hear your issue still persists! I am working closely with Gayani.
As these workarounds don’t help, can you please reach out directly to the support team with a copy of your file: here
This will help us to investigate further where the issue may come from.

Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com as an Editor (this won’t affect your billing at all) so they can take a closer look. Thank you.

The same here. For the last week or so, library updates have been painfully slow. We literally have to sit in front of the screen and observe how instances update one after another at the pace of one instance per second.

Cleaned the Figma App cache—same slowness in the browser.

I have a overview component that houses all my 100 instances so that organisation users who use the library directly or the agencies who download and import a local copy of the Figma file will know what components are available in 1 look. But fetching this particular component update takes 3 minutes on the desktop app. This would mean that everyone who uses this Figma file will need to wait 3 minutes just to update that compoent and have their cursor move again.

Not sure if there is a better way of displaying all variants on a page?

  1. App or browser, loading anything from libraries still takes 10+ seconds each time I go to use it. Tried on multiple networks, Mac and Windows.